Selection nightmare

Please see the attached video. I have to deal with this all the time. It slows me down and makes working in Rhino a pain.
selectproblem.mp4 (1.2 MB)

Absolutely true

Hi Tobias,

What (customized) display mode are you working in?
I see this behavior only in a display modes with transparency set in shaders.


Hi Willem, thanks for pointing me in the right direction.
What I used was my rendered display mode. So I created a copy of it and hit “Restore Defaults” on my Rendered mode. It fixed the problem! Then I reapplied all customization one by one to see where it goes wrong but it didn’t show up again.
So I am sorted. Thanks!

Btw, now I also remember having the same problem years back with imported display modes from V4. Restoring the defaults fixed it too.

thanks, Tobias

Ok, I rejoiced too soon… it worked for an hour or so and now it shows the same problems. What could possible be wrong with this display mode? I did nothin really special… basically a gradient background and changing the lighting scheme to “Default Lighing”.

I’ll attach the display mode so maybe, hopefully someone from McNeel can have a look and tell me what I do wrong.
Rendered-TNL.ini (11.8 KB)

This looks like something @mikko can help with.

If you’re in a rendered mode and the material on the surfaces in front or their layers have even 1% transparency you see that.

the material has 0 transparency:

The only theories I have is the object may be locked, on a layer that is locked, or the object is somehow invalid and makes the picker bail out. Otherwise I can’t think of a reason why it would be completely ignored when picking.

Can you window/crossing select it? Can you select it in other views? Can you pick it by clicking where there’s nothing else behind?

Hi Mikko,
Some answers to your questions:

Can you window/crossing select it? Yes
Can you select it in other views? Same problen in all views as long as I set it to rendered view mode
Can you pick it by clicking where there’s nothing else behind? Yes

If I switch to shaded there is no problem.
Ghosted shows the same problem (which you guys say this is to be expected but I wonder why to be honest)

thanks, Tobias

I’ve lately started working in Ghost view as that allows for some semblance of overall geometry but does allow for selection of various geometry that would otherwise be hidden from view. This does, of course, lead me to switch to rendered view to get a better feel for a recent addition, modification or completion of geometry. You can also set rendered features in ghost view if you want. Don’t know if that helps, but it may…cheers, Rob

Hi Tobias,

Can you please send the model directly to me, Saved small if possible, and perhaps with just a couple objects in it that demonstrate the issue. So far I haven’t been able to get anything like this to happen, and I’m running out of ideas. Thanks.

actually, i get the same problem quite often. I’ve found that clicking near the edges of the surface helps (especially directly ON them).
Now i’m no fancy engineer from McNeel ( :slight_smile: ) but here’s how i explained it to myself - it probably has something to do with the display mesh. If you click in an edge-less area, it tends to favour the nice “denser-per-pixel” edges of the smaller objects behind it. No?
It’s actually something i’ve been struggling with as well, so I’m really keen to see which way it goes.

This might be stupid direction but it worth to try. We faced same problem with other 3D program when we choose some options related to OpenGL. It looks the same, because we can select only faces behind. After disabling hardware acceleration (it was option in program under OpenGL settings), it is working ok. With new generation of the computers (new graphic cards), this problem gone no matter what option was in OpenGL settings.

In our case that was graphic card related how OpenGL acceleration is handled.

Hi Roberto,
I’d like to note that disabling hardware acceleration might indeed fix the issue, yet it should not be used as a permanent solution. What it basically does is disabling the videocard and letting the CPU do all calculations, thus you loose all advantages of the videocard.


I know this is not permanent solution, but just suggestion where to experiment with another graphic card or other driver or Rhino development can suggest or take care somehow…

1 Like