Selecting in shaded view

Shaded mode seems to rely too heavily on picking an edge of a surface or mesh. If I select the “center” or the surface it will always select something beyond. I noticed working in one of our custom modes that is based off of shaded I did not have the same issue. Has anyone run into this or know of a fix?

OurShaded.ini (12.5 KB) OurCustomShaded.ini (12.6 KB)

Moved to Rhino for Windows category.

Hello - can you please run SystemInfo in Rhino and post the results?

@devinperkey - it appears to be related to the backface color setting- if backfaces are colored,selection becomes dodgy. I’ll get that on the bug- heap, thanks for pointing it out.

Hmm- that is only part of it, it looks like… still digging… Ah, it is the transparency on the backfaces:


When that is not zero, the pick goes through the object.


Thank you! We’ve been struggling with this throughout the whole R5 lifecycle. Hopefully it gets bumped in prio list. :crossed_fingers:

1 Like

system info.txt (1.8 KB)

Hi - have you tried setting the transparency of the backfaces to zero, as Pascal pointed out?
While this is not supposed to be a permanent fix, it could help you along until RH-53491 gets fixed.

It defeats the whole purpose of that display mode. It’s like a Shaded + Ghosted from behind hybrid mode that’s really convenient when modeling looking at the front of geometry or from the backside.

Yes setting the transparency of the backfaces to 0 fixes the selection issue but like you said I hope that is not the permanent fix because that defeats the purpose of having that as an option.

RH-53491 is fixed in the latest Service Release Candidate

1 Like