Selection acting strange on latest Rhino 7 release

Selection is acting strange, specially in Shaded viewport when I have curves and surfaces overlapping with each other. Selection menu is not appearing and usually prefers to select the surface like if the curve wasn’t existing at all, this can be noticeable by doing a simple loft between 3 or 4 curves.

Is someone else facing this issue?

Release Version
(7.0.20314.3001, 9/11/2020)

I can upload a video if needed.


Hi Gonzalo- can you post an example like the curves and loft that you mention, so I can have exactly the same file you do?


Selection Bug Example.3dm (105.8 KB)

There it goes :slight_smile:

Hi Gonzalo - thanks… not selection problems here - I assume there are no selection filters active, and that the curves select if the surface is not there?
Can you look in Options > Advanced > Rhino.Options.ModelAid.MousePickBoxRadius … what is the number in there, (default is 10) and are you using a high resolution screen?


Hey Pascal, there are no Selection Filters active and I can select the curves when de surface is not there. I can actually select the curves with the overlapping surface as well but only after several attempts.

The number I have for the option you mentioned is 7 as default, not 10 (I never changed it). I will set it to 10 then, maybe it came like this with this release.

I am using a regular 1920x1080 screen, not a 4k or anything similar.


I just tried by changing the number to 10 but it doesn’t help either, I even tried with higher numbers like 15 and it’s the same problem.

Selection windows are working fine.

Best Regards,

Hi Gonzalo - I guess 7 makes sense with a 1920 screen - it looks like that is the default there. I see your other note as well… I am not getting any other bright ideas… yet.
@gszechter - can you please run SystemInfo in Rhino and post the results?


Rhino 7 SR0 2020-11-9 (Rhino 7, 7.0.20314.03001, Git hash:master @ 9d1a3d02b292e00d3480c301d33f414d91acdcbd)
License type: Educacional, build 2020-11-09
License details: Cloud Zoo

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1070 (NVidia) Memory: 8GB, Driver date: 9-14-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.38

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-14-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @pascal,

I see the same behaviour as the OP unless I change the advanced setting SnapToOccluded from the R7 default value of False to True, after which the curves are selectable and the Selection menu appears when expected.

This behaviour is different from R6 where the curves are selectable regardless of that setting.

@gszechter, this is the setting:

Note that I don’t know what side effects you will experience if you change it…

(Credit to @Helvetosaur for highlighting this setting in another thread)

EDIT: Sorry, false dawn - see subsequent post


Hm - this setting makes no difference in selection, here, so far… which is in itself a good thing, I would say. But Jeremy, did you also see the selection difficulty ?


Hi @pascal,

I did see the difficulty, then I changed the setting and it worked. Now I have gone back to it and it doesn’t!

I remembered that I had rotated the view slightly so i did that again and the selection worked so I reset the setting to False, tried again and it didn’t work. Rotated again and it did.

So it seems the setting probably doesn’t have any effect, but changing the view can do. But I also tried randomly selecting surface and curves and witnessed the curve selection work then stop working. Then sometimes work again after another view rotation, before ceasing again. And if I can pick one curve it doesn’t mean that I can pick another.

It also seems that if the surface is selected, a curve is selectable only at very limited distance(s) along its length.

New factor: If I maximise the perspective viewport the selection behaviour gets better (not perfect). FWIW I’m using a high def screen.

EDIT: Zooming in also improves the selection behaviour

I noticed the same thing, depending on the place where I’m picking the curve, selection menu may appear or not. I noticed that this is not happening when the curve is over an edge of a surface or polysurface.

Tested it with the same file on R6 and selection worked properly there, so it should be a V7 problem.

Hi @pascal and all
I’ve been meaning to report this for ages, but haven’t had the time to do a full write-up of what I’m seeing. I have actually gotten to the point where I switch to ghosted view as second nature when in V7. I’ll have to try the
SnapToOccluded that @jeremy5 mentions
and see if that makes any difference. I’m still on the latest/last beta and not at work, so no sysinfo from me right now - but I’ve been seeing this for some time. Just never got around to get anyrhing done about it :unamused:

Thanks everyone, I am bugging the developers for some feedback.


1 Like

Hey guys,
Can you please try running “TestCloneOnSelectionMap” command to see if that changes selection to work the way you expect? I added a this test command a while ago when I made some changes to the selection code for optimization purposes. If that command fixes the issue, then we know we’re looking in the right spot and we can figure out what to change.

Hi @stevebaer,

tried your test command and unfortunately it didn’t make any difference.

(Rhino 7.1.20329.13011, 11/24/2020)


Same result as Jeremy over here.

Version 7
(7.0.20314.3001, 9/11/2020)

Thanks for letting me know. Back to the drawing board I guess. @mikko any ideas of what to try?

I’ll investigate. This has nothing to do with the zbuffer based depth culler added to V7, or snap to occluded. The latter does not affect picking in any way. This is all related to object pickpoint in general basically being some random location on the object within the pick rectangle, and how the pickpoints get compared in the basic picklist culler that tries to determine what to keep and what to throw out. The culling does not happen if the view is ghosted and the transparency is set to at least 2, so that’s one workaround for the time being.

RH-61819 is fixed in the latest Rhino 7 Service Release Candidate