Selection acting strange on latest Rhino 7 release

Thanks @mikko, @brian, now working as expected.

Sorry, but I don’t see any changes for this issue on version (Rhino 7, 7.1.20343.09491), maybe it wasn’t stated correctly.

The curve not only cannot be selected when overlapping with an edge, but also when the curve is at the same place as an isocurve or when it overlaps within any part of the surface geometry. The selection menu only appears after several attempts and on certain spots.

Best Regards,

The latest service release candidate is for 7.2. This is where the bug was fixed

Rhino 7 SR2 Release Candidate 1 for Windows and Mac (7.2.20343) is now available

Sorry, I’ll check it out. The automatic update had just downloaded the one I stated.

For Service Release Candidates:
Options > Updates and Statistics
Update frequency: select Service Release Candidate
Check now

1 Like

Now it works perfectly, thank you! :slight_smile:

Rhino 7 SR2 2020-12-8 (Rhino 7, 7.2.20343.11011)

Best regards,

I am experiencing selection issue with Version 7 (7.2.21012.11001, 01/12/2021)

Video shows the difference in selection behavior between Rhino 6 and Rhino 7. Rhino 7 starts at 13 second mark. As shown selecting through transparent objects is virtually non existent in version 7.

Is this a design decision?

I was searching the web for solutions for this problem. Ended up here discovering, that this problem is there since the early versions. I’m now on Version 7 SR24 (7.24.22308.15001, 2022-11-04) and the problem is still there.

You can’t select edges through objects by clicking. You have to use the selections rectangle, which is likely to select more than you want and not always practicable.

The same or similar problem occured with snapping. You simply cant snap to an edge, when the visual mesh of for example a polysurface is in front of it, even it’s not behind an object. You have to move the camera around or you have to use the ghosted view.

A solution to the snapping problem is the “snap to occluded objects” option - as mentioned in this post before. But this doesn’t solve the edge selection problem.

I am repeating the question of ->spineribjoint1<- : Is this a design decision?
Looking forward to your replys!

Sorry, but does nobody has an answer to that?

@Pulser can you share a (simple) model that shows this behavior?

Hi Pulser- can you also run the SystemInfo command in Rhino and copy/paste the results here?


Rhino 7 SR26 2023-1-9 (Rhino 7, 7.26.23009.07001, Git hash:master @ 92abcf7c453c78a236526390d91d0ac1f6779143)
License type: Commercial, build 2023-01-09
License details: LAN Zoo Network Node Checked Out

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [50% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 7-21-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3050 Ti Laptop GPU (NVidia) Memory: 4GB, Driver date: 9-12-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 517.40
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-12-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.26.23009.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Sample - Rhino 5.3dm (23.1 KB)
Sample - Rhino 7.3dm (35.1 KB)

Shall I make a video for demonstration?

Hi -

At one point, in testing here in Rhino 7, I actually got it to select the edge, but only after clicking 10 or so times. When I tried that again, I wasn’t able to reproduce that after clicking about 30 times. So, yes, I see what you mean.

In the Rhino 8 WIP, we are experimenting with mouse-over highlighting. It looks like that makes selecting an hidden edge while in a command rather easy:
2023-01-13 Select Hidden Edge


Hi Wim, thank you for reply! At least I’m not alone. Which makes it also worse, unfortunately. The mouse over highlighting looks good to me and might be very nice for unskilled users. Would be nice to choose between edge and surface highlights. Too bad, that it is not possible to build a work around for rhino 7 to act like at least rhino 5 in shaded viewport. Anyways, I’m looking forward to any suggestions. Have a nice day!

edit: the second I replied to wim I had an idea, which I tested immediately:
As I mentioned it is possible to select through objects in ghosted viewport. So you can set the transparency from any viewport to “1” which enables you to select through objects without loosing the “look” of the viewport.

In my opinion its solved now. Thank you guys!

Sorry for the late reply …

I did manage to fix this a while ago or it was fixed by McNeel with an update. Not sure but now I can’t replicate the “Problematic” behavior.

I remember duplicating the default “Rendered” display mode and turning on edge thickness for surfaces. It seems different modes had a different depth buffer methods.


sorry for the late reply also. I’m glad that you fixed your issue. Mine is still there, and I’ve learned to live with it. Somehow, my fix, that I mentioned in the post earlier, still works as you can see in the clip.