Problems with sub object selection, doesn't work in v7 but does in V6?

i have a model here that has been throwing me fits. I can’t do subobject selection on the faces or edge of this object in v7 but when i copy it over to v6 i don’t have problems.

kyle helped me out with a technique to fix the surfaces in another thread but i came in today, did some edits, joined them back up into a solid and am unable to do subobject selection.

he originally thought it was the source geometry possibly being from other software but i opened all my source files from this company and they all originated from rhino.

i have been taking the model, exporting it as igs, importing into solidworks, editing, exporting out as igs, go back to rhino. i thought maybe solidworks was wonking the file, but i just exported from solidworks, opened in v7, doesn’t work, copied model over to v6 and it’s fine. so it’s not SWX i assume.

any ideas?

v7.3dm (84.4 KB) v6.3dm (84.7 KB)

ok, now it’s getting weird… this works fine for me in v7 and in v6…
(7.0.20223.23135, 8/10/2020)

did you try the v7 and v6 file i posted in the other one? i just tried again to do a sanity check and i’m not crazy. :wink:

i’m on:
Rhino 7 SR0 2020-8-11 Public Build, 7.0.20224.11375

yes, the single surface misbehaves in both v6 and v7… the polysurface you posted behaves fine in both…

huh, there are a couple of faces in the polysurface i can subselect but almost every one is unselectable. in v6 everyone is selectable.

@pascal any ideas? sorry to ping direct, been dealing with this for a few days.

here’s system info:
Rhino 7 SR0 2020-8-11 (Public Build, 7.0.20224.11375, Git hash:master @ 80ed87da5e00958b9ec0c70a7dd48b9653030465)
License type: Commercial, build 2020-08-11
License details: Stand-Alone
Expires on: 2020-09-25

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Hybrid graphics system.
Primary display: Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 3-9-2020 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 5-22-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 397.93

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  Anti-alias mode: 8x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 5-22-2018
  Driver Version:
  Maximum Texture size: 32768 x 32768
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 32768 x 32768
  Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
  C:\Users\monke\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\iris\0.6.6\Iris.WinR6.rhp	"Iris"

Rhino plugins that ship with Rhino
  C:\Program Files\Rhino 7 WIP\Plug-ins\Commands.rhp	"Commands"	7.0.20224.11375
  C:\Program Files\Rhino 7 WIP\Plug-ins\rdk.rhp	"Renderer Development Kit"	
  C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoRenderCycles.rhp	"Rhino Render"	7.0.20224.11375
  C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	7.0.20224.11375
  C:\Program Files\Rhino 7 WIP\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
  C:\Program Files\Rhino 7 WIP\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
  C:\Program Files\Rhino 7 WIP\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	7.0.20224.11375
  C:\Program Files\Rhino 7 WIP\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	7.0.20224.11375
  C:\Program Files\Rhino 7 WIP\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
  C:\Program Files\Rhino 7 WIP\Plug-ins\Displacement.rhp	"Displacement"	
  C:\Users\monke\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2020.7.6.347\PanelingTools.rhp	"PanelingTools"	
  C:\Users\monke\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2019.7.29\SectionTools.rhp	"SectionTools"

Hm… I am not much use here - everything that I tried in the V7.3dm file and the errors.3dm file sub-object-selects as expected so far.


i just noticed that i can cross window select and get subobjects.

i just took my v7 file, saved it out as v6, opened in v6, subobject select ok, opened the v6 file in v7, subobject works, saved that file out as v7, reopened that v7 file, subobject selection doesn’t work. so something must be happening in the v7 save?

OK - I get it now, messing a bit more I see this is an IGES import - I believe this is this bug, at least partly:

RH-3894 All one edge

I will see if I can bump this bug- it rears its head from time and it is a pain to deal with…
See if this helps for now - (2.6 KB)

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"


thanks pascal. unfortunately, i ran it on all the surfaces, rejoined and still can’t select subobjects.

i did notice that subobject select does work on vertexes.

i had this old rhinoscript you wrote laying around and tried it and it fixed them. strange.ReTrim.rvb (6.0 KB)

hm - so the errors.3dm file … if you open that and isolate one surface, you cannot Ctrl-Shift click and edge and see the entire loop selected? That is (I thought anyway) part of the problem - you don’t get the obvious individual edges… the script was meant to fix that - it splits up that loop into the obvious edges.
But, if you cannot get the Ctrl-Shift to select at all… then I am back to square 1…


scratch that, the rhinoscript worked, but when i reopen the file i can’t subobject select. what the heck is going on? lol

I just want to be sure what this means: ctrl-shift-click does not select any subobject (edges, faces in a brep for instance) at all? Or the edge is selecting but has reverted to the full edge loop? or?
And does this work on other objects in the same file - for instance, add a box…


yeah, ctrl-shift-click. it works on a new box. it’s not selecting faces or edges, there are a few that i can sub select.

i’ve never had this problem before so i’m just going to go back to v6 and do what i need to do.

It probably has nothing to do with this problem, but I notice your Nvidia driver is over two years old. I have the impression from the forum that that’s way too old for Rhino v7.

Just sayin’.

that’s strange i just updated it from the nvidia website 3 days ago.

@kleerkoat - can you send me the Iges file that is lurking behind all of this?



here’s two files from the same customer, both gave me fits. thank you.

@kleerkoat - thanks - just be sure you know this is a public forum - delete these files if that is a problem and PM me in the future…


thanks pascal, i totally forgot about that.