Section interferes with shadows in the Conceptual view mode

Rhino 6.29.20210.4411
VisualARQ 2.8.4.14192

I’ve set the Conceptual display mode to show shadows. After playing a bit with it I noticed that toggling section interferes with how shadows are displayed (even if the section is placed in a position where it doesn’t cut anything).

Section Off


Section On

Conceptual shadows settings

Hi @Czaja,

Actually, the bug is the first screenshot, as it seems VisualARQ is not taking into account the “Shadows ignore user defined clipping planes”. I think plan section and sections are both “user defined”, so when this option is enabled, shadows will render as if section was not enabled.

We’ll let you know when we fix this issue.

Enric

Actually, the bug is the first screenshot

Yes, I agree, I put them in order that may suggest otherwise. :wink:

Anyway, these view modes look very nice, so eliminating the last bugs would make them really great.

Thanks!

Hi @Czaja,

I’ve been trying to fix this issue, and I almost fixed it, but there is a problem with shadows and the section slices. The problem is that if I don’t disable the clipping plane, then the computed shadow map, and the ambient occlusion, affect the slices, and the result is not looking good. It seems like if there were no slices at all.

The problem is that there is no Rhino SDK function to disable shadow map when drawing meshes, so I contacted McNeel asking for a new SDK function. They will probably add those methods, so I guess in 1 or 2 months there will be VisualARQ version with this issue fixed.

Regards,

Enric