VisualArq 3D Plan printing

Hello
I am trying to use the 3D plan view in Layout on Rhino 6. I would like to have a diagonal hatch over a solid colour in the wall sections.

I have figured out that if use shaded display mode and with the “show fills” box ticked in the Clipping Plan objects section then a get the look I want. It display perfectly in layout, but when I print it, there are white strips in the walls.

Can anyone help with fixing this problem? or help with an alternative solution. I am trying to avoid using 2d sections, I would rather see the live model.

Thanks

SHADED_MODIFIED.pdf (554.5 KB)

Hi @shirahockman,

Can you sene me the model to visualarq@asuni.com?

Printing shaded details is a Rhino feature, and VisualARQ does nothing special. They should be printed like you see them on the screen, as they will use “Raster Output” mode.

When Rhino prints in “Raster Output” mode, it divides the paper in tiles, and print each tile separatedly, because OpenGL doesn’t allow very big buffers. I think that the while lines may be just in the union of these tiles. The fake “solid hatch” is painted by VisualARQ when using level cut planes, so maybe there is a bug there…

Thanks,

Enric

Sure, I will upload now.

Weird that the white tile issue only affects the walls running across the page and not the ones running up & down the page…

I think it has got something to do with the fact that rhino is trying to shade inside the walls. If I use other display mode settings like Arctic of Rendered, there are shadows on the interior of the walls.

Yes, I though the same. But maybe the bug in VisualARQ is related to how we calculate the viewport height, while the width is correctly calculated.

But I’m just guessing. Maybe the issue is related to something different, or even isn’t a VisualARQ issue, who knows! I’ll try to test it later today.

Enric

I cannot reproduce the issue. Here is what I get after setting my “Shaded” display mode like yours:

32c_milmay_park_20180729.dm.pdf (183.1 KB)

Which PDC printer are you using? I’ve tried “Rhino PDF”, “Microsoft to PDF” and “CutePDF”, all with similar results.

Which settings do you have in the printer?

Also, can you send me the model that you’re trying to print? The one you sent me has the detail in “Wireframe” mode… maybe is not the same model.

Regards,

Enric

Hi Enric

I uninstalled and reinstalled VisualArq today (as per our conversation in another post) and now I can produce the issue. Although, I still get similarly strange results using Rhino, Adobe and Microsoft PDF writers:

VISUAL ARQ 3D PRINT_shaded_adobe pdf.pdf (1.7 MB)
VISUAL ARQ 3D PRINT_shaded_microspft pdf.pdf (1.6 MB)
VISUAL ARQ 3D PRINT_shaded_rhino pdf.pdf (1.8 MB)

Here is my working file:
VISUAL ARQ 3D PRINT.3dm (4.7 MB)

Hi @shirahockman,

I cannot reproduce the issue. I’m using the latests public version of Rhino and VisualARQ:

  1. Rhinoceros 6 SR7 (6.7.18210.11281, 07/29/2018)
  2. VisualARQ 2.2 SR3 (Build 12616, 2018/07/30)
  3. There are no more plug-ins installed:
    image

If I open the 3DM on your last post, and print it, I get a vector PDF. I guess I need to put the detail in Shaded mode. After that, if I print it using Microsoft to PDF, I get this:

image

As you can see, there are no while lines, but the image is not equal to yours, as the floor on my print is grey, while in yours is white. Are you sure this is the same file? Do you have any other setting changed? Do you have any other Rhino or Grasshopper plugin installed?

Enric

Hi Enric

Thanks for your continued help on this matter.

Here is my shaded display mode file:
Copy of Shaded.ini (12.5 KB)

Here is the environment file:
Studio.renv (12.5 KB)

With Regards to Plug ins, I have section tools and a camera lens plugin installed (http://www.filmcad.com/Rhino/) but they dont show in the list of of “Plugins that do not ship with Rhino”:

Grasshopper now ships with Rhino so that is intstalled,

Here is a list of all my plugins:

Hi @shirahockman,

I’ve been trying to replicate your issue, without success. There is clearly something wrong in your Rhino + VisualARQ related to print. Do you have another computer to try?

Enric

Hi Enric
So i tested it on my mac using bootcamp and I got a vector pdf. So I felt like there was maybe a problem with my copy of Rhino on my PC. I uninstalled and Reinstalled both Rhino and VisualArg and now the hidden display mode is printing as a vector PDF.

VISUAL ARQ 3D PRINT_hidden_va installed.pdf (68.9 KB)

So that part of the problem is atleast solved!!

The next part of the problem, is that I would like to be able to create a print that has section walls diplaying with a solid colour and a hatch over it. Like in this screen grab:

Which has this display mode setting: Copy of Hidden WITH SHADING.ini (11.4 KB)

But print like this when using Rhino PDF (or anything else):
VISUAL ARQ 3D PRINT hidden with shading_va installed.pdf (211.4 KB)

Is it possible to achieve this using either display modes or section attributes? Or is it just not possible?

Please ignore the heading on this print, its incorrect. Its a Rhino Pdf in VA default Hidden Display mode

You can only achieve that if you print the model to Raster output and you use “shaded” display modes (not Wireframe or Hidden).
(See image below)
You can use the wall color (1) for the fill color in section, a Section Pattern (2) that will be shown on top of it when showing the wall in section, and a specific Pattern color (3) to differenciate it to the wall color.

In any case we will try to implement the option to have a fill hatch pattern different than the Section Pattern and print that to vector output.

2 Likes