Conceptual View Mode: No Shadows, Custom Modes not Saved

On the weekend I was pleasantly surprise to discovered that with Conceptual View Mode I could get reliable section fills, Va Section Fill Patterns, textures, contour lines on curving surfaces, and ambient occlusion and other shadow methods. I created several copies of Conceptual with different levels of shadow intensity.

Today there are two problems:

  1. None of the copies I made of Conceptual View Mode show up in Options, though the project was saved with them created. I created a new one and for this morning at least it appears to persist after saving a project.
  2. Turning shadows on has no effect in a Conceptual View Mode, regardless of the lighting setting. (They still work in Rendered Mode)

I’m using 2.12.0.15342 on up-ti-date Rhino7

Hi @djhg,

Starting from VisualARQ 2.12, changes in VisualARQ display modes “Hidden”, “Conceptual” and “Realistic” are persistent. Also, display modes copied from those are also persistent, but they will be only available if VisualARQ is loaded.

Display modes are never stored in a 3DM, they are per application, this is how Rhino works. For example, if you move from one computer to another, you will need to export/import display modes.

This seems like a bug, but I cannot reproduce it. Did Rhino/VisualARQ crash after you created those display modes? If Rhino crashes, it is possible that the display modes never got stored in the computer.

Shadows seem to work fine on my computer with the default “Conceptual” settings after enabling the “Shadows” option in the “Display” panel:

image

Can you share your conceptual settings INI and the 3DM file you’re using?

Thanks,

Enric

ihave sent you a link to the project. and the ini file, which I have also attached below.
ConceptualAOTexturesShadowsNoWorking.ini (13.0 KB)

I can’t get AO shadows in Hidden Mode either. It works in Realistic mode, but I can’t get render materials to show up there. It’s not just the project I sent, it’s any project. I updated my display driver last week, but maybe there’s another update. Just verified that all my drivers are up to date (not with device manager but the manufacturers) and even updated my display driver to the gaming version incase that makes a difference. Nothing seems to improve the situation.

Hi @djhg,

You need to enable the “Shade objects” option. Without this option enabled, object meshes are not drawn, and it is impossible to show any kind of shadows.

Enric

Thanks Enric.