Scripts and Rhino 6


I’m having an issue where scripts are no longer functioning in Rhino 6, some of which I rely on a lot at work.

None of the scripts here are working for me.

I also have create outline and random layer color scripts that no longer works.

Has anyone else encountered this?


Hi John - let mew know which scripts and what the error messages are and I’ll see if I can tune them up.If the error message refers to ‘Line 1’ then drag and drop the rvb file onto an open Rhino 6 and it should sort it out - installing for V5 does not carry across to v6.


Hi Pascal,

Thanks for the quick reply. I just noticed I’m getting this response at the command line when I drag and drop a .rvb script into the viewport, or go through the menu bar.

Command: _-LoadScript
Blocking plug-in RhinoScript.
Unknown command: _-LoadScript

I’ve unblocked the script, and when I run Rhino 6 in admin mode I can no longer drop the script into the viewport. Perhaps this isn’t an issue with code but Windows 10 permissions.

I’m trying this with the “get clipping plane curves” script


Hm - it does seem like some wires are crossed - LoadScript is unknown then the RhinoScript plug-in is not loaded - does the EditScript command work? If not, look in Options > Plug-ins and make sure the RhinoScript.rhp is enabled and loaded…


1 Like

That was it, thanks. The Rhino script editor was loaded, however the RhinoScript rhp was not.

Thanks again for your help,

I had a similar problem. You will probably find that the Rhinoscript plug in will keep failing to load. I did a repair on my Rhino installation and it seems to have solved it.


1 Like

Thanks, appreciate it.

i have same problem LoadScript command doesnt work. _EditScript works. Pls to reinstall Rhino did hepl? What mean to “i did a repair on my Rhino installation”?
Rhino Version 6 SR23
(6.23.20055.13111, 24.02.20)

Hi - in the Windows Control Panel, go to Uninstall a program:

Then find Rhino 6 and right-mouse-button pick Change:

Then pick Repair: