Rhino Script Error in Rhino 6 after installing the latest Rhino 7 WIP

Hello,

I’m getting the following error when I open Rhino 6. This seemed to occur after the installation of the latest Rhino 7 WIP.

image

I tried to run the “Repair” from the Windows Control Panel and get stuck with it looking for Bootstrapper?

Any help would be much appreciated!!

Thanks,
Jason

Oh FYI… I uninstalled the latest Rhino 7 WIP to see if this would help, it didn’t, but when opening Rhino 6 afterwards I had to reinput all my licensing for Rhino 6.

Hi Jason - if you click No (is that what you are doing?) on the first dialog and then carry on using Rhino, does it all work? Does it happen every time you start Rhino?

@brian - I also see this from time to time but I cannot repeat it or see a pattern.

-Pascal

Hi Pascal, you are correct. I click “No” and nothing gets resolved and I continue having issues with my plugin. This happened many times and then I finally clicked “Yes” and don’t get the pop up anymore but the plugin still isn’t working.

Hi Jason - by this you mean RhinoScript.rhp, correct? If you click No, RhinoScript still does not work in that session?

-Pascal

No… Sorry for the confusion. When I said “plugin” I meant the Conveyor plugin from Proving Ground and Nate told me that this error that I’m getting with Rhino Script is the reason that it isn’t working.

If I click “No” then I still can’t use the Conveyor plugin.

After messing around with it for awhile, I don’t seem to be getting the error… Can you tell me, how can I verify if the RhinoScript.rhp is working correctly?

Hi Jason - type ‘RunScript’ and Enter - that should do something and not return ‘Unknown command’. Also in Options > Plug-ins page, RhinoScript should be present and enabled. To be sure, right-click and choose ‘Load plug-in’ if it does not show as loaded…

-Pascal

I checked and… When I click “No” when the prompt comes up, I can use the command ‘RunScript’ but I think the fact that I need to click this everytime is what is preventing Conveyor (Rhino to Revit plugin) to work… When running Conveyor inside of Revit it is trying to open Rhino in the background and is getting stuck with this prompt.

I checked the Options>Plugins and RhinoScript is present and enabled, but now when I close Rhino and reopen I get the prompt about RhinoScript.

Hi Jason - I see. I’ll see what I can find out.
@dale - do you have an idea?

-Pascal

I’m trying as a last resort to uninstall and reinstall Rhino 6 as I really don’t want to reinstall all the plugins and user settings… Is there a way to possible “Repair” Rhino 6? I’m not sure why it was asking me to open Bootstrapper when I tried to Repair earlier.

Hi Jason - here is a shot in the dark that might, or might not, help until we get this figured out - try saving and then drag/drop the attached script file onto Rhino. Then restart Rhino. Does anything behave better with respect to the plug-in?
Startup.rvb (297 Bytes)

-Pascal

Are you using any anti-virus software beyond Windows Defender? Sometimes these AV applications mark the RhinoScript DLL as a potential virus by mistake.

After trying what you had suggested I wound up with new errors when using Conveyor in Revit and it still didn’t work. :frowning:

We use Symantic… There were never any issues with this before this last Rhino 7 WIP update. Do you think there could be an issue now because of the update?

Hi Jason - ok, nuke that script - my thought was to force RhinoScript to load when Rhino opens by giving it a startup script.

-Pascal

Will do

I couldn’t really guess. Probably worth trying to repair your Rhino 6 installation with and without Symantic turned on.

Thanks Steve… I tried both with Symantec on and off and always get stuck at this BootStrapper

So I tried uninstalling and reinstalling Rhino 6 and still get the Rhino Script error after a new install :frowning:

@brian any ideas on what could be happening here?