Saving as PDF issues

lates WIP explodes closed paths to single segments - files cannot be postproduced in illustrator (fills etc.).

Actual stable version keeps in exported pdf all polylines closed.

I’ve noticed the exploded single line segments too. I have a Lexmark C925, but I think this theory has been offered before so I tried connecting another printer, a Samsung ML-2240 and this didn’t resolve issues. Seems odd that it’s fine in Raster output though if it’s to do with the printer driver. If no printer was connected, can you not “Print to PDF”?

Finally solved this. It is not a printer driver issue. I started methodically testing all the possible printing combinations and found that when using fixed scaling and vector output, setting non-zero print margins in the Print dialog would change the location of the output image. This will be fixed in the next WIP release. In the meantime, you can set the margins to zero in the Print dialog to get correctly placed images in your PDFs.

Still researching the exploded paths issue.

1 Like

Hi @epiphany-

Thanks for reporting this. Unfortunately, I’m having trouble reproducing this difference in behavior between 5.3.2 and 5E63w (the latest RhinoWIP as of today). Can you please provide the file you used (the 3dm), the export/printing steps, and the steps in Illustrator to demonstrate what you are seeing? I tried to reproduce what I think you are reporting, but I came up with the same result each time.

Here is what I did:

  1. Created TestPolylineExportToIllustrator.3dm (3.0 MB) in Rhino 5.3.2.
  2. Navigated to Print > Output: Vector > PDF > Save to PDF… and named the file TestPolylineExportToIllustrator_5_3_2.pdf.
  3. Opened the same file from step 1 in RhinoWIP 5E63w and repeated step 2, this time naming the file TestPolylineExportToIllustrator_5E63w.pdf.
  4. In Adobe Illustrator CC, I opened TestPolylineExportToIllustrator_5_3_2.pdf. I selected the Groups, right-clicked and selected Release the Compound Paths. I think selected the curves in bottom-most path (the rounded one) and right-clicked to Join them.
  5. I selected both polylines and filled each.
  6. I repeated steps 4 and 5 with TestPolylineExportToIllustrator_5E63w.pdf.

I got the same result for each file. What are we doing differently?


Hi dan,
please try this 3dm file:
example.3dm (4.4 MB)
steps to reproduce:
Rhino: Layout - Print - Vector output - Save as PDF
stable version output: output01.pdf (609.0 KB)
WIP version output: output02.pdf (608.6 KB)

In Illustrator (CS6):
Release Clipping mask - select eg any chair - Release Compound Path


  • stable version output keeps closed polylines closed
  • WIP version output produces polylines broken into single segments (unable to fill).

Thanks for sending along those files.

When I start with your example.3dm, I am not able to reproduce the issue in 5E63w when using the Print > Save to PDF. This is a screenshot from the output produced by 5E63w that I created

When I use your output02.pdf, I am able to reproduce the issue, but only on certain curves, like the arcs…

…but not with many of the other closed polylines…

It is bothersome still that I cannot reproduce the issue from the 3dm file you provided, but I think I see what you are seeing with the output2.pdf that you provided.

@marlin any ideas?

@dan The original issue is that 5E63w and 5.3.2 produce different results. It is not clear to me that you have confirmed that issue.

I am not able to produce different results between 5.3.2 and 5E63w with the example.3dm file that @epiphany provided above following the steps he provided.

I am able to see that output01.pdf and output02.pdf provided by epiphany behave differently in Adobe Illustrator.

I think, It could be related to blocks/trimmed circles?
stable version pdf output in Illustrator:


Create new file
Create circle/polyline with arcs, trimm that circle and create block.
Copy block, edit block, offset circle, Apply
Test PDF outputs in Illustrator

The step you have provided do not produce a closed shape.

If I presume that you checked the Cap (Flat) option when Offseting the Arc, I get results that fill in Illustrator like this, regardless of whether or not I use 5.3.2 (stable) or 5E63w (WIP)…

I do not see a difference between 5.3.2 and 5E63w, but it certainly doesn’t look correct to me.

It doesn’t matter if the shape was closed or not. Trimmed circle is interpreted as single (closed)curve in stable version compared to multiple segments in WIP.

Could you test it with Epson drivers, please?

Sure. I am getting consistent results between Rhinoceros 5.3.2 (5D197) and RhinoWIP 5E75w using Epson drivers.

At this point, I’m lost; I don’t see what you see…and I don’t actually know what you expect to see. I am able to create closed curves from Rhino, Save to PDF, and fill them in Illustrator without issues…in both 5.3.2 and the current RhinoWIP (5E75w).

Perhaps you can post a simplified 3dm, please? If you can also post detailed steps for how you created this model, that would also be appreciated.

expected results: closed polyline is opened in illustrator as closed curve, not exploded single segments.

Looks like there is new WIP relased now, I’ll test it tomorow.

On my machine, a closed curve created in RhinoWIP (5E75w) that saved is to a vector PDF and opened in Adobe Illustrator CC opens as a closed (compound) path that is easily edited and filled.

I look forward to hearing what you experience in RhinoWIP 5E75w.

Yes, great - thank you, that works now!

Seems to be fixed in latest WIP. Thanks @dan

Not sure if this is the same issue other people are discussing but I am getting a ghosting effect where certain lines ghost through the solids.

This is what I see in model space (this is displaying correctly)

This is what I see in “Layout” display (and when I print) …

If I zoom in to the layout …

and zoom in some more, it goes away …

These are my print settings …

Any ideas how to make this display/print properly?

When I hide the other objects in the file. It displays properly…


I have tried SelectBadObjects and it says that there are no bad objects in the model.

I have Audited and it says: No errors.

Does reducing the value for testZBiasFactor help here?

A post was split to a new topic: Cannot print to PDF