Saved Camera Positions


#1

Hello,
Is there a feature that will allow you to save camera positions in Rhino 5, so you can go back that position at a later time?
Thanks in advance, George


(Pascal Golay) #2

Hi George - use the NamedView command/panel for this.

-Pascal


#3

George, one great thing about namedview is that you can name the views with simple names like r1 (short for render 1) or v1 (view 1) etc.
Then while working you can just type in the name quick and easy and voila you’ve restored your named view w/o even having to go find it in a panel.
This feature alone is possibly one of the top ten reasons I love Rhino as much as I do. If anyone knows of another 3d cad app that lets simple things like this become keyboard commands on the fly like this I’d love to know what they are…

I use this little button macro to facilitate the naming of views as I use this feature ALOT! :
! _-NamedView Save
_Pause _Enter


#4

I have found inconsistencies using named views. I am rendering a 2 week animation on my computer with Bongo 2 and Flamingo nTX. After a computer shutdown in the middle of the animation, I had to continue where I left off. During this process, the animated perspective window needed to be readjusted due to Rhino changing toolbar locations (darn it). The continuation of the animation had a slightly different size than the original, so the named views did not bring the image exactly back to the original and I had to restart the animation all over again. Also, I had locked exposure settings in Flamingo nXT and sure enough, there were differences in the new rendering exposures, again forcing a restart of the process.

If anybody has any ideas of how to lock in exact rendering parameters so Bongo can continue, I would surely appreciate it. Since the rendering window can not be manually set for an exact size, I can not see how it can be done. Perhaps saving with a floating window for the animations would work, independant on the standard viewport sizes and toolbar layout.

Regards, Ray


(Andrew le Bihan) #5

I’m afraid I’m no Flamingo expert, but I can help you on a couple of points:

  1. The exposure issues will almost certainly be fixed if, in addition to checking “lock exposure” you delete the first frame from the output folder before re-running the animation. This will force Flamingo to set the exposure from the absolute first frame - as it did the first time.
  2. Always use a fixed output size when rendering animations. You should be able to replicate the view size by opening the already rendered images in the output folder and determining their pixel size from the properties dialog. Then go back into Flamingo and set the output size accordingly.

#6

Thanks Andy.
Good advice on exposure. I am still a bit confused since I had previously locked the exposure and the new parameters were the same, yet the exposure was brighter. The rendered view size is the same and is locked in by Bongo 2. I think what happened is that the perspective viewport window size changed slightly and must have changed the camera parameters a bit. I am now halfway through the renderings (again) and hope that the computer stays alive. (only 980 more frames to go at 8 minutes a frame LOL) When the computer shut down before I believe that Windows did an update without my permission, thus rebooting the computer. I disconnected the internet to prevent further Microsoft intervention for the rest of the rendering process.

Thanks again for your response. Regards, Ray