S-L-O-W Meshing

I ended up with one complex solid part worth of 210 MB. If I work in shaded and try to perform any type of modification, re-shading will take 14 minutes. Yup, not a misprint. 14 MINUTES to create shading meshes…! In rhino 5 the same part with same mesh settings shades in around 15 sec.

Please tell me there is some switch I’m not aware of I can flip to fix this, otherwise I have to shelf Rhino 6, at least for this project.


Do you have shutlining, displacement or edge softening on your object?

Hi Nathan, no non of those applied. Thanks.


@pascal do you have any ideas why this could be slow?

Hi Darius - does the object ring up with SelBadObjects ? If so, try ExtractBadSrf, hide the resulting surfaces and see if that cleans up the meshing - then, … fix the surfaces.


1 Like

I just fixed bad surface yesterday and it was fine but it looks like my following up modifications produced another bad object this morning again. Thanks for the ( obvious ) suggestion Pascal…:slight_smile:


Pascal, After fixing 3 bad surfaces, surprisingly all 3 are flat panels which were never affected by any of my latest modifications, and I had to use V5 to do fixing because V6 took forever to join them back, now shading takes around 12 minutes. Diagnostics show no naked or non-manifold edges and there are no bad objects…


Have you tried adjusting mesh settings to a bit faster?— Mark

Thanks Mark but mesh settings is identical for V5 and V6 so why such discrepancy in time to shade. Changing setting doesn’t fix the issue.


OK so I uploaded chunk of my big solid here:https:https://we.tl/hXIj51jeLL
It’s V5 format. My mesh settings see below.
Is there anything funny going on with this part that would cause such differences in shading time…? If you find anything please let me know. Thanks.


Looks like this issue has been forgotten… me included…:slightly_smiling_face:

Unfortunately my client asked for some further modifications and all the issues relating to this solid returned with full force and than some.

Model is about 200 Megs so if I’d like to make it available to you where can I send it safely…?

Besides shading which takes around 14 minutes here there are some additional findings which might be of interest.

I will send you this solid with few sections disconnected from the main part. So not solid anymore.

  1. To connect them back with the main segment, if I start <Join> command and than pick elements the entire sequence becomes painfully and I mean painfully slow

  2. On the other hand preselecting parts and than clicking on <Join> makes command complete in only a few seconds.

  3. After you join all parts into one solid try and shade it. Here I can go do my grocery shopping and by the time I’m back my part is just about to be shaded. And please compare to Rhino 5 performance. Mesh settings are all 0 except “Maximum distance edge to surface” .001

  4. Having one solid in wireframe please untrim few portholes and than shade it again but this time don’t wait until it completes. Cancel it instead after a minute or so. Here when I did that, and I can repeat it although not every single time, I might as well and forget about saving this file. It’s not gonna happen. Rhino just getting stuck and the only way to stop it is from Windows Task Manager. In fact when I do this, after couple of bad experiences when the entire system become unstable I usually reboot my system to avoid any further complications.

To be honest it’s rather frightening when saving couple of hours of work become impossible…


Hi Darius - please SaveSmall, zip and send via

www.Rhino3d.com/upload to my (Pascal) attention.



Thanks Pascal. File send. Good luck investigating.


Hi Darius -I see - thanks, I think this is an example of what @DanBayn was reporting as well. I certainly see the V5/6 discrepancy in this file.

(My wild guess of the moment is that this may be related to the large number of trims. I tried a fairly complex model here that is not chock full of trims and there was no difference in that case.)


Sidenote: It looks like Darius scene has a modell problem, but couldn’t we get a parallel meshing of multiple objects for mult core CPU? Meshing is quite slow and at my Dual Xeon only using a little fraction of the CPU power.

The meshing is much faster when the (huge) polysurface is exploded first.

@nathanletwory, you can get that by enabling “Jagged seams” in the mesh options without exploding, but that would result in open edges between adjacent faces.


@nathanletwory - there does seem to be something up with joining - ExtractSrf on a very complex brep is also extremely slow in V6.
Explode is not slow though… weird. OK, I’ll add these details to the YT item - good catch.

There seems to be a threshold, though, below which there is little or no difference - in both ExtractSrf and meshing. (trying to create a file small enough for YT that shows the problem)


Yes, I was just trying to point this out. Not offering solutions here :slight_smile:

We still have the same issue. Did you have any solution?