Rotating a Family After Placing

Hi There,

I have been using Rhino.Inside Revit to place columns along a curve. I have the normals at the point of placement, which i was going to use to rotate the columns, however they all place according to world xyz. I tried rotating all the plane, then using the new rotated plane as a host, i tried rotating the geometry afterwards in grasshopper, which gave null results. I tried hosting the columns to a curve, and rotating the curve.


I could create a rotation parameter within the family itself, and then map the angle to that parameter. I feel like there must be some simple thing I’m missing.

thanks in advance,

A

I also noticed something strange when placing Families at given rotation.

Hi @process.aw,

As @Czaja showed in its video addFamilyInstanceByLocation takes a plane as an input.
The component honors the plane orientation when inserting new instances.
It had a bug and didn’t work well the first time it creates the family instance.
Now it’s fixed, so could you please update and confirm is fixed on your side as well?

I noticed the same “lag” with populating windows inside walls.

I am having similar issues with rotating a family. I am testing some of the features and attempting to populate a vertical surface with an individual brick family I created. I am getting the error “Can’t rotate element into this position.” I tried using the host parameter by inputting the individual planes for the rotated bricks then using the center point of those planes for the location, but that also did not work. The example image is just using the planes as the input location.

The brick family is at 0,0,0 and oriented in the same direction as they are on the surface. They just aren’t rotating when pushed to Revit. I have edited the family to be “work plane based” and that also did not work. They stay vertical with no rotation. Any ideas why they wouldn’t be rotating?