Right Mouse Button Rotate

Hello,
I have somehow accidentally changed or disabled my Right Mouse Button = rotate view. Now my RMB only pans, and I have to hold “shift+ctl+RMB” to rotate. This is annoying, because I am so used to the other way, and I find it much more intuitive. How do I change my settings back?

I have tried all the different options in the settings window, but nothing seems to change.

Thanks,
Siri

Hi Siri - un-check the ‘manipulate view’ setting for the middle mouse button. Any luck?

-Pascal

Hi Pascal,

I have tried that, to no avail.

Well- in parallel views that are plan to the Cplane, you only get to pan - use Ctrl-Shift to unlock the plan view and tumbling is allowed. It should work in perspective views though.

-Pascal

Yes, I thought that might have been the problem (that I had accidentally tumbled an ortho viewport) but that is not the case. I have reset my viewports, and in the perspective viewport, I am not able to rotate using just the RMB. I have to hold “shift+ctl+RMB”… and it’s tripping up my workflow. :(pensive:

PASCAL I am >insert unflattering adjective<.

I had “parallel” rather than “perspective” checked in “viewport properties”. How silly. Sorry.

1 Like

OK, I’m glad that’s sorted!

-Pascal

Hi Pascal! what if my Rhino 5 not unlock the plan view after i use Ctrl+Shift, rmb still only can Pan unless i hold Ctrl+Shift. Please help, thank!

Hello- most likely you have, in Options > View page, set the option for ‘Always pan parallel views’.

-Pascal

Hi there, I’m running into the same issue. When I click the right mouse button, it only moves the object but doesn’t rotate it. I don’t have manipulate view checked. Also ctrl + shift + RMB doesn’t work either.

This just happened to me and was resolved by closing the file and reopening. Doesn’t answer the question of how and why it happened in the first place, but perhaps just a glitch.