Perspective View Won't Rotate

Sorry to ask such a basic question but Perspective View rotation by holding down right mouse key seems to have gone away. I looked into Viewport Properties and it is set for Perspective. I tried hunting for previous questions of this type but I am not the best finder of things.

So the blindingly obvious solution is . . .

Hilary Smith
Olympic Peninsula

Hi Hillary -

Have you tried the 4View command to reset all views? You might have to run it twice…

Yes, I did that.


What happens when you do try it?

As far as I can tell, there is no change to the Perspective View response to right click mouse movement after 4View twice. That is, it still does not rotate.

But what does it do? Nothing ? Or pan?

Without actually knowing that my first guesses are that there is some Windows “accessibility” feature–easy to turn on by accident–or other mouse mapping software messing up the right-click, or your mouse has physically died.

Have you locked the viewport?

Will restart the machine to deal with the Windows issue. And no, the viewport is not locked – thanks for the suggestion.


Restarting Windows did the trick. I’ve got Rotation back in Perspective – and learned a little in the process. My great thanks to William, Jim and Nathan – all was very instructive.


I restart Rhino every time, but I find using command: '_RotateView OR ctrl + shift + RMB could rotate the view again for me.


Change projection from parallel to perspective

On mac i also have the same problem… you need to restart view port. i dont know where it is but “4 views” and you get back control. It should be in view options or edit…