RhinoInside.Revit Element.Geometry error : Failed to found one and only one closed loop

I’m trying to read some panels into Grasshopper and I’m getting this error on one of them.
It seems to be closed, with edge lengths being similar to other working panels. When I export solids to DWG, it opens in Rhino as a closed solid polysurface.

Does anyone know what might cause this? Possible fixes?

Thanks

Hey Bushdylanj,

Are both panel families the same family? If so you might look at how they are built, or other family elements within that system.

I ran into this issue with walls a while back with some the walls category. While I am not sure if this is the same issue as you are running into, but in my case the issue was actually a nested window family having multiple opening cuts. Once I fixed the nested family it worked perfectly.

There was an opening cut modeled in “Window B” & “Window A” separately, which were used to make nested family “Window AB”. This meant there was not a singular opening cut within “Window AB” and instead separate openings in the original window families. This was causing RiR to throw the error of a one and only one closed loop. Once I remade the family to have a single opening cut in nested family “Window AB” it fixed the issue and worked perfectly.

Anyone else have any other experiences with error and found a different solution?

1 Like

Yes, they’re different types of the same family. I’m not sure how the panels were modeled, but visually I don’t see anything that separates the panels that are working from those that aren’t…

I suspect it might be a duplicate edge or something like that, but I’m not sure how to evaluate the Revit geometry