Rhinoceros Imported Solid "Issue"

Hi everybody! I’m using Rhino for a class project. I made a cigarette box, even though a part of it is a solid imported from google sketch up:

My problem is right that imported solid (white wireframe). Even if its properties are the same of the other parts ( in line type, color, material, etc…) it doesn’t behave the same way, as you can see in the upper pic and in this other one

I have even problems when export this whole file to Autocad, in fact, if I choose the “shaded” display type the file is still in “wireframe” view, while this particular solid is in shaded mode, so, again, it works with different rules from the other parts of the file. I hope I’ve been clear enough and hope you can help me, thanks in adcance,

Enrico Labarile

Hi Enrico - my guess is it is a block instance. Use ExplodeBlock and see if it behaves differently.


I tried to explode but still nothing changes, those polygons which are imported have still a white wireframe.

Can you post a Rhino file with the objects?


I suspect what you imported from Sketchup is a mesh object. What does Properties say about it?

You should be able to import it as a surface object, there is an option on import IIRC…


Here it goes, thank you very much

My connection won’t help uploading the files, I try what Mitch said and then I try reuploading, thanks all for the support :smile:


By the Way, the properties say in fact that it is a “closed mesh”, I guess you’re right


In Rhino land, meshes are very different critters than NURBS surfaces and polysurfaces.
They should never be confused.

I converted the meshes to polysurfaces but still the same, nothing changes. If that helps, the other polygons are “Extrusion Solid” type.

If you still have the Sketchup file, I would try deleting the imported Sketchup mesh object and re-importing it. When importing it, there should be an option in the import dialog or just after to import as surfaces and not meshes. If you check that, you should be good to go (I hope). --Mitch

Cairo.3dm (2.4 MB)

You used MeshToNurbs to do so? If so it should work more or less OK. If what you are seeing are color differences, you might have some objects set to color by layer and others set to color by object. If you had render materials applied in Sketchup they might also show up in Rendered mode in Rhino.


you should probably just redraw stuff like that… here it is without the mesh.

Cairo_nomesh.3dm (2.7 MB)

OK, got your file. The inside parts (wavy cigarette holders) are still meshes. As Sketchup can only do flat planes, the cylindrical parts are just facetted representations of the smooth circular surfaces. I would just use those as a guide and re-make them in Rhino for a better quality model - those are not hard objects to make. Make a rectangle, circle, array the circle and do some trimming/joining to make the profile, then extrude. Takes like 5 minutes.


Thanks for the tips, I used that way because I still do not know to make the cigarette holders properly in Rhino, I started using Rhino just lately. Anyway I will give it a try :smile: Thanks everybody!

understandable… it’s worth taking the time to learn how to do that in rhino as you’re going to get much better results than in sketchup… plus, it’s easier/faster to draw that in rhino anyway compared to sketchup once you have a decent grasp on the available commands/methods available in rhino. :wink:

Spend a few minutes and skim through the User’s Guide. It will give you some good tools for using Rhino modeling techniques.

Good luck

Here’s a quick video… Sorry, the osnap tooltips don’t show up very well and it’s kinda jerky…