Rhinoceros and microsoft edge

Hi, this morning I unistalled microsoft edge from my win10, and my rhino 6 started to get bad… is there any correlation?
ps I unistalled microsfot edge because of I never used it and the system used it to open pdf files, everytime I had to change with adobe

No real way of knowing unless you can specify the way Rhino6 gets “bad”.

Since MS doesn’t provide an official way to uninstall Edge, you probably have hacked your system. This may or may not have consequences for other programs. Generally you should not expect your system to work flawlessly once you remove or modify anything that is not meant to be removed or modified.

PS: you know, you can permanently reassign the default PDF app? If that keeps resetting for some reason, you may have other issues on your system.

Hi, yesterday I formatted my computer and installed again Rhino with SR13; and today I have the same problems, the program does not work well, it often gets stuck and this time the computer is clear.

I have a win 10 pro original, clear and update, maybe the SR13?


Please run the Rhino SystemInfo command and post the result here.
After a fresh install of the OS, most likely you will have to update the drivers of your GPU(s). Don’t let Windows decide that these are fine, you will have to check on the manufacturer’s site for the latest drivers.

Hi, this is SystemInfo of my Rhino:

Rhino 6 SR13 2019-1-31 (Rhino 6, 6.13.19031.5531, Git hash:master @ ac8b9292dc95031d2b575d143268a63e738fe068)

License type: Commerciale, build 2019-01-31

License details: Cloud Zoo. In use by: fmataraz ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Machine name: DESKTOP-04IU4NV

Hybrid graphics system.

Primary display: Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-28-2018 (M-D-Y).

Primary OpenGL: NVIDIA GeForce GTX 1050 (NVidia) Memory: 4GB, Driver date: 1-30-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 418.81

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 8x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 1-30-2019

Driver Version:

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 4 GB

Rhino plugins

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19031.5531

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19031.5531

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19031.5531

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19031.5531

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.8.24.259\SectionTools.rhp “SectionTools”

Thanks for that information - nothing looks to be out of the ordinary there.

Can you be more specific about your workflow and where things get stuck?

in this period my workflow is simple, I’m working on a model of simple house, there are only planar surfaces and 8 curved surfaces, I did many of these with Rhino and I know that it’s not a problem; when I uploaded the SR13, Rhino started getting stuck, there isn’t a problematic command, can be happen with a pan or a line; I tried with many files, in case of damaged file, but with this SR every files have the same problems… I’ve been working for more ten years with Rhino, more or less with similar models and similar workflow, and never I had problems, I’m a Rhino fan!

Do you still have SR12 laying around to check if it’s really SR13 that is causing you trouble?

I’m trying to uninstall the SR13 version but everytime the exe file
with SR12 , downloaded directly from mcneel site, has the SR13 already installed; which is the folder with the last release? I can’t find it.
ps I noticed that the PAN COMMAND is the problematic command, when I use the pan with the right button the program gets stuck

Make sure that you are not signed up for release candidates but only service releases before you uninstall Rhino. Then, from https://www.rhino3d.com/download/Rhino/6.0/release, you should be getting 6.12.19029.06381.

Hi, I unistalled all the folders with Rhino 6, becouse of everytime it was updated to SR13, and installed the release from https://www.rhino3d.com/download/Rhino/6.0/release, now I have not Rhino 6 in my computer even if the says it has been installed correctly.

what’s happened?

I really don’t know.

How do you uninstall a folder?

Did you make sure that Rhino wasn’t going to download and install release candidates before you uninstalled?

One thing to try is to set your Nvidia to high performance in its control panel. Recently hybrid system like yours have been suffering these problems.

Hi, I have the same problem with the new SR13 and with V7 wip too… my GU is on performance setting and the sr13 was installed by Rhino automatically…
what can I do?

I need old service release 12, where is it?

Hello - you should have an installer here:


Search for 6.12


nothing, only 6.13

Hello - try


But, @fmataraz - what is it that went wrong with Rhino, exactly?


it’s ok, I installed it but started with 6.13

I’m sorry to begging on request but I need to use Rhino, and in this way it’s impossible… I tried to install sr12 but everytime run the 13, what can I do?