Rhinoceros with Windows 10

A few days ago I updated the system to Windows 10. And I have a problem with work in Rhinoceros. My Rhino often freezes, and I always have to restart your computer. This happens when I start to do in the program after a short break. The application is still open. Does anyone have similar problems in windows 10?


I have been seeing some issues with graphics card drivers in win 10- apparently when you do the upgrade, win does NOT update your graphics card driver. I had two pieces of software that plain wouldn’t run for more than a second (not rhino) and caused me to downgrade back to win 7- Upon further searching, it appears that a graphics card driver update may have fixed my issue.

Give it a go and see if it helps- I’ll post back when I re-upgrade and try again if it fixes it here- I’m running an nvidia k600

I have a quadro 4000 and it works perfectly (on windows 10), not seen any issues on neither machine…
But then I installed the dust collecting AMD FirePro v7900 on one of them to see if AA had been improved over the years (they had not) and the whole system became unstable and froze on a few occations. So AMD is still delivering really bad drivers. The drivers were really hard to find too as they had just been moved out of beta… (They were not done at the time Windows 10 shipped).

Needless to say it is now collecting dust again… and the quadro is back in the game for now :slight_smile:

So what kind of graphiccard to you have?

I’ve been having freezes in Chrome with Windows 10, always(?) just after waking up. Sometimes they require a hard restart, sometimes they work themselves out. Rhino has been stable since I updated the video drivers though.

I’m running a GTX 650M.

Could be that the problem occurs when windows activates screensaver or try to freeze active process to lower energy load.
A way would be disabling energy saver options in windows (or putting bigger values) and see if the system is more stable.

Thank you for ansver
So I use computer with Intel i5 and GeForce GT 740M. Of course I updated drivers.
Perhaps the best option would be to re-install Windows 10?

Basically, I do not use energy saving options, but I’ll check it. Perhaps my laptop switches to low-energy.
Thank you for advice.

FirePro W7100 is rock solid in Win10

1 Like

Runing an HP EliteBook 8760w Mobile Workstation
with an AMD FirePro M5950.
The labtop was under Win7. As it had slowed down with the years, I have done a blank installation of Win10. My graphic card was no more recognised as a FirePro M5950 but as a Radeon card and I had similar issues with Rhino solved after an update of the graphic driver. My graphic card is now recognised as a FirePro M5950.
Unfortunately, Rhino is much slower now than previously with Win7. I have sometimes to wait for several minutes because the program is ‘Not Responding’. I had to disable AA, mesh quality set to jagged, starting (even a new file takes 30s) or saving is very long (I am typing this text while saving a Rhino file).
Beside the Rhino part, wifi doesn’t work (driver problem) and specific labtop features (screen brightness, sound volume keys …) are no more working.

Have you tried bios update (There is one from this year), and then install all Win 8.1 driver
Driver HP
ChipSet (If new)
If not works, otherwise looks bad, possibly switch to a Quadro card


I’ve made a blank installation too (the upgrade didn’t work on my old SSD 128GB disk so I’ve put a new SSD 256GB);
As @eddi has suggested, the motherboard drivers aren’t installed, so I’ve had to put the original DVD and install all the old drivers… after that Windows made some upgrades; now it seems to work quite well.
The SO’s speed is more or less the same as Win7… could be that on starting up it’s a little bit faster…

Same issues with my new notebook. While running Rhino4 with the recent service release and RhinoCAM 2.0 on an older notebook ( I7/1) with a Nvidea GT250 graphics module is fine. my brand new notebook with I7/7 GTX1060 freezes rather on every mouse click ( usually 2 double clicks on the top view port update the screen and allow to move the mousepointer again, but just until the next freeeze two clicks later. Rhino 5 runs fine but is not working with Rhinocam 2.0. I 'd hope there is a fixture out for this.

check to see if there is a graphic card update for that gtx- it will likely cure the issue. Especially if your driver is more than a year old…

I checked the status quo and found a driver dated 3/18 … newest version is 6/18
So I will update and check out… thank you for that hint!

Missed… same problem with the latest driver setup. The reason might be that the nvidea chipset is mainly developed for 64 bit and Rhino4 is 32bit… but it seems that the intel onboard graphics is functional on a much lower performance…

Hello - try setting Rhino 4 to run in ‘Windows XP’ compatibility mode on the new machine.


Rhino runs on win 10 but the problem serms to be more GPU related since the standard graphics chip performs low but well and the gtx courses issues however Ill have to split my processes and go for design with the gtx and do the CAM process on the intel gpu chipset