Rhino7 Bug: causing crash with AMD graphic card driver

Hi - I am using rhino7 in windows 10 on my desktop and ran into a weird issue yesterday that I have no idea how to fix.

I was trying to import a cad file into rhino and after the dialog box said " successfully imported" the model space still looked empty. Assuming it just imported far out I tried to zoom extents to find the cad at which point I got an error message (attached) that said essentially AMD bug driver timeout. I tried to trouble shoot and checked for updates/updated rhino and all of my rhino plug ins. As a side note, my windows 10 updated yesterday. After each update and option I tried, I would still get the error message.

To be clear, I can open this file in autocad with no problems and was able to open the import the cad file into rhino on a different computer with no problems, so it is not the file.

However, after updated my graphics drivers and trying again, now anytime I try to open ANY rhino not just import this cad file, my pc completely freezes and the only way out is a hard restart. I was able to borrow a second graphics card and after putting it in and testing it, rhino is running fine on the new graphics card.

I am lost on what to try next, it seems like the graphics card drivers and rhino aren’t playing nice together for some reason but how to fix it I don’t know.

Other perhaps helpful information:

  • My graphics card that isn’t working is a Radeonpro WX7100
  • I have had this graphics card for 2 years and used with rhino extensively before yesterday’s issues.

AMD bug timeout error

In Rhino Options > View > OpenGL
Uncheck the option for using GPU tessellation.

Any better?

1 Like

That worked! Thank you so much!