Rhino6 laggy viewport performance with 3dconnexion

I’m having some terrible issues with a laggy viewport after I’ve imported a large 2d general arrangement into my model.

Are there any settings I can fiddle with to optimise viewport performance with large 2d drawing data sets?

Graphics card is an Nvidia Quadro P5000 running on a laptop.

Many thanks in advance!


Oh, by the way, performance is fine in V5.

Are your Quadro drivers current?
Is there a linetype pattern assigned to the layers or curves that you have to Zoom WAY in on to even see?

Thanks John, good point about current drivers - I updated my desktop not long back but the laptop is new to me (although second hand). I’ll check the nvidia site now.

No linetype patterns assigned to layers, just lots of lines. Yes, they will be very small when zoomed out - see attached pic, the blue deck plans at the bottom are about 140m long. The lag doesn’t go away when zoomed in close.

Checking drivers now, will report back…

Window select a bunch of curves.
In the Properties Panel, is the linetype all By Layer or Continuous?
If it’s (Varies), then I think you have curves with a super tiny pattern that is making a boatload of curves to display.
Zooming in close was to see if that’s the case.

Ok, nvidia driver now updated. No difference.

Line types were different. Changed them all to ‘by layer’ and no difference.

One thing I have noticed - the lag seems to be an initial lag, so if you switch from zoom to pan to rotate you get the lag between navigation ‘requests’. Once you’re navigating it’s all beautifully smooth. This becomes very obvious when using the 3d connection space thingy - keep the navigation going then it’s super smooth. Pause and restart it briefly and you get the lag - almost like it taking time (a little too much) to calc a scene optimisation or something prior to starting the navigation.

What happens if you unplug the Space Mouse?
Is it OK then?

Back on the linetypes thing…

  1. Get the name of one of the line types being used.
  2. Go into Options > Linetypes
  3. Look at the pattern definition and select the one you know is being used
    The numbers are the length of the lines in model units. If they are very small, add a model space scale so make them big enough to see on the screen. When the pattern is big enough to actually see, then it son’e be bogging down performance.

Unpluged the space mouse and still the same.

Line types were set to 400 model space scale. Changed them to 5000 and then 10000 and then 1 - all behaved the same, with the initial lag.

One other thing to try…
There are some Quadro settings that might help.

  1. Right-click on the Desktop and run nVIdia Control Panel
  2. Under 3D Settings > Manage 3D settings > Global Settings tab > Global presets:, choose "Workstaion App - Dynamic Streaming.
  3. In the Setting section below, set Power management mode to “Prefer maximum performance”

Any better?

1 Like

Tried a few of those presets but with no difference, even with it set to the catia preset (for my ICEM Surf).

Power management was already set to prefer max performance.

I’m out of ideas short of getting the file with the curves in it.
If you want to stage it somewhere I can get at it, I’m happy to see if I can figure anything out.


Is there a lot of text in that model? If you run SelText and Hide, does the performance change?

It reported only four bits of text, when hidden there was no difference.

I’ll prepare you a download link John, thank you.

Just sent email with download link.

Your file acts fine here, but there are a couple of possibilities:

  • 59 Bad curves
  • Maybe a plug-in gumming up the works
  1. Try running SelBadObjects. Delete, Hide. or move the bad curves to a layer that’s turned off.
  2. In Rhino Options > Plug-ins, set the list filter to Plug-ins that do not ship with Rhino. Disable them and restart Rhino.

Do either of those get your performance back?

Deleted bad curves. No improvement.

No plugins listed under plugins that do not ship with Rhino.

Disabled the 3d connexion plugin anyway, just to try. No improvement.

Downloaded the latest drivers for the 3d connexion. No improvement.

That’s bizarre.
My Quadro isn’t as fancy as yours and it runs fine.
I’ll see if @stevebaer has any ideas.

I have the file Steve.

Ok, thanks for trying John. Perhaps I need to just draw everything from scratch in V6 (rather than importing an old GA to steal bits from) and see how the performance goes as the GA gets more detailed.

Please make sure to restart Rhino after disabling the 3d connexion driver. I doubt that is the problem, but just to make sure.

Ah ha! Thanks Steve, restarted Rhino after disabling the 3d connexion plugin and the navigation works beautifully!

Is this something I should notify the 3d connexion people of or is it a RMA written plugin?

1 Like