Rhino 7 is laggy in viewport

No matter what kind of file im working with, my rhino 7 is laggy while rotating or zooming. its perfeectly fine in rhino 6 whith the same models. any help?

Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15001, Git hash:master @ 190335c3fb65efe86c302714a8959a7dadfe667b)
License type: Commercial, build 2021-08-10
License details: LAN Zoo Network Node

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [99% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 6-24-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro RTX 3000 (NVidia) Memory: 6GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

Secondary graphics devices.
Citrix Indirect Display Adapter (Citrix Systems Inc.) Memory: 0MB, Driver date: 1-23-2019 (M-D-Y).
> External USB display device with 8 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2021
Driver Version: 30.0.14.7247
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\Proving Ground\Conveyor\ProvingGround.ConveyorRhinoInside\ProvingGround.ConveyorRhinoInside.rhp “Conveyor Rhino Setup (Rhino 7)” 2.2.2.0
C:\Program Files\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.21201.1426
c:\Program Files\Solemma\ClimateStudio\bin\ClimateStudioRhino.rhp “ClimateStudioRhino” 1.4.7867.27445
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 7\Plug-ins\GenslerRhino.PlugInLoader\2.1.0\GenslerRhino.PlugInLoader.rhp “Gensler.Rhino.PlugInLoader” 2.1.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.9.21222.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

The NVidia settings used to swtich the GPU, but now Windows is. Is it being done correctly? Under Window Setting Graphics Settings, you should see something like this, though it might be using light colors.

(I have the other setting off for battery life, but I should research that more.)

Yes, that’s the same as yours.


and my graphic card is a good one. It’s a Quadro 3000. which should work even better.

I also have a Quadro A3000/Notebook. It’s been working pretty well for me, under Cycles, too. Though, it only has 6GB of memory. For very large projects that might be an issue.

Could it be that processor performance is turned down. If it’s a laptop, is the computer getting hot?
Is it V-Ray’s preview, or Rhino?

Obviously, must to have enough memory, or the computer will use into virtual memory, but if you have enough memory, adding more will not help.

In an already saved and backed up, saved file, you can open up the task manager using [CTRL][ALT][DEL] once, and then chose Task Manager. From there, you can check memory usage. The GPU usage will be low, because it only works for DirectX. You can select Logical Cores, in the CPU window to see which each core/thread is doing. There is a Kernal Time option, too.

I use Open Hardware Monitor, and set widgets on my desktop to keep it all in view.
https://openhardwaremonitor.org/

I believe that even if Window now handle the Optimus-style switching, the nVidia applet still finely controls the GPU, and the settings may be set high for other things, there. You can make a custom Rhino profile in the nVidia app, and make sure the GPU settings are all reasonable and good for Rhino.

In the screenshot below, please notice that I made a custom profile for Rhino. Whenever Rhino starts, it should still apply these settings.

Your settings AA seem moderate, ok: Anti-alias mode: 4x
But, if you have a 4K 15" laptop, this can be lowered, perhaps to 2x : )

Currently, you have: Anisotropic Filtering Mode: High
Unless you are using a lot of high-res textures, looking down long hallways and streets, this can be set to lower anisotropic filtering here, or turn it off when you are only modeling shapes:

Generally, you don’t want many triple buffering and pre-rendered frames. This will prevent your GPU from cooling–before you move. It’s useless during translations and turning the view, if it the GPU cannpt guess what your next move would be.

In the nVidia settings, there is a low latency mode. That’s a keeper.

Power Management. Please watch your laptop cooling!

The shader cache is a silly waste of SDD endurance/wear.

The maximum Framerate can be set the what your monitor does. I would keep it at 60FPS. Why? Because it’s not about the ensuring the fastest frame–but preventing the slowest. Let the GPU cool whenever it can.

The texture filtering is something also to check. Not a lot of savings, but a penny here, a penny there.

Vertical Sync is nice, but it costs framerate unless you have Freesync, or whathaveyou. There used to be adoptive options, but not any more.

Threaded optimization should be on. It would probably guess this, but what the heck.

Also, a cool laptop is a happy laptop. Putting something safe and small under to lift it for more are is good, but I don’t recommend non-factory fan cooling pads because if the airflow goes the wrong way, it will stall the air inside the laptop. Even a upsidedown mesh letter tray will cool it, also long as the laptop is stable and secure.

For my P15-Gen2, I put some cooling lifts on Thingiverse. They were made with this program called Rhino 3D. Perhaps you have heard of it. : )
https://forums.lenovo.com/t5/ThinkPad-P-and-W-Series-Mobile-Workstations/P15-Gen-2-3D-Printable-Cooling-Lift-Feet-Might-Work-on-P17-Gen-2/m-p/5106413

Other things you can do to prevent latency:
Use lightweight extrusions whenever possible.
Lower your system-wide meshing setting.
Use Blocks for objects whenever possible when doing large projects.

Let’s try something…

  1. In Rhino Options > Plug-ins, change the list filter at the top to ‘Plug-ins that do not ship with Rhino’
  2. Disable all of them
  3. Close and restart Rhino

Does the problem go away?
If yes, systematically enable the plug-ins one at a time, restart, and isolate which one is cause the slowness.

Can you identify a plug-in that is causing the problem?

1 Like