Rhino6 crashing on launch after Win10 upgrade

…but I’m not sure if it was caused by the Win10 upgrade or something else.

Crashes on launch from taskbar or after opening a rhino file from the finder. I did a repair with the installer and also uninstalled with win10 and reinstalled from a freshly downloaded installer.

I turned on debugging, attaching that file: RhinoDebugMessages.txt (15.6 KB)

Opens in safe mode, system info follows. Per another crashing bug on the forum I updated my Intel UHD Graphics driver but that didn’t change anything.

Rhino 6 SR14 2019-5-7 (Rhino 6, 6.14.19127.17141, Git hash:master @ 5b633aaa430941b76f5789a0ce3bb670ce06947a)
License type: Educational, build 2019-05-07
License details: Cloud Zoo. In use by: j. eric townsend ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: SLICER

Hybrid graphics system.
Primary display: DisplayLink USB Device (Unknown) Memory: 0MB, Driver date: 11-8-2017 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P3200 with Max-Q Design (NVidia) Memory: 6GB, Driver date: 3-18-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.71

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y).
DisplayLink USB Device (Unknown) Memory: 0MB, Driver date: 11-8-2017 (M-D-Y).

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 3-18-2019
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19127.17141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19127.17141

Looks like you have your computer on a docking station? If you unplug it from that, does it fix anything?

I would think that unplugging the Dell DisplayLink will “fix” the crashing, as Mitch says, but that might not be the ultimate solution for you?

It looks like something, likely the Windows update, messed up GPU drivers on your system. I would therefore also do a clean install of both Intel and NVIDIA drivers following the recipe posted here:

Make sure to include step 4 of the uninstalling process!

I do have it on a Lenovo docking station and it’s worked fine in that configuration for a few months. That configuration is my office where I also run Adobe CS, SolidWorks, the Qt IDE, and some 3d printing slicers.

Right now I’m at the “second office” (aka “dining room table”) with just the laptop and Rhino is loading and running just fine. Will leave it running, put my laptop to sleep, then return to my office with the external monitor and see what happens.

edit: running just fine after waking from sleep on the external monitor. Exited, re-launched, and Rhino6 crashed. Will follow all of the above steps and update.

In Device Manager I uninstalled (including deleting the driver), rebooted, reinstalled, then test launched in this order:

  1. Intel UHD Graphics 630
  2. ThinkPad USB 3.0 Ultra Dock
  3. NVIDIA Quadro P3200 with Max-Q Design

Rhino died each time on launch.

Noting that it launches just fine in laptop mode, I opened my laptop, kept my Dell as a second/mirrored monitor, and launched Rhino with no problems. Closed the laptop, opened an existing file, and Rhino crashed.

Opened laptop, launched with Dell as a second/mirrored monitor, and opened a file, no crash. This is not very usable as the Dell resolution drops from 4k to the 250% magnification used on the laptop. Closed the laptop and Rhino doesn’t crash.

I’m wondering if this is more related to opening a file than the graphics drivers but I also haven’t looked at the debug logs / files.

[edit: fixed a thinko]

I strongly suspect the graphic drivers.
I also suspect that the nVidia GPU is not selected for Rhino, in the Nvidia control panel.

With Max-Q, I might also avoid the “Maximum Performance” power settings in the nVidia control panel, opting for the “Adoptive” or something else that takes less power, so that the GPU can cool a little bit, here and there.

I usually run nVidia’s drivers, downloaded from their site–over old-fashioned, factory branded ones.

Ok, so here’s the problem. The Lenovo laptops with NVIDIA cards can only direct-drive the laptop display or an external monitor connected to the laptop. Up until a recent Lenovo change, you could “cheat” and use the not-NVIDIA-not-fast alternate graphic card via the Lenovo USB dock. Video out from the laptop goes over USB, the dock converts that to DV, and things are fine. It’s fast enough for CS6/Word/Qt that I’ve just used the convenience of one-less-cable when I dock. (I spend half my hours outside my office, often in studios or fab spaces.)

I moved my monitor connection from the dock to the laptop and now all is good with Rhino and SolidWorks, which was also crashing going through Dock “but has always worked before”.

Thanks for sharing your changes, that is some good information in case someone else runs into the problem!