Rhino 6 crashes on startup

I have already sent in an error report (the one that pops up when rhino crashes/closes) but was wondering if there are other people having the same issue. I updated to the newest version (which I would think is the most likely culprit) but also downloaded some plugins for grasshopper at the same time. After restarting the computer I can’t open new or old documents, I get the error reporting pop up right away.

I tried uninstalling all the new plugins as well as deleting them from the computer. I updated my computer and checked to see if my graphic cards were up to date. Restarted computer again, same problem. Everything was working fine a couple of hours ago for me.

I am able to open in safe mode. Am I missing something obvious?

Rhino 6 SR31 2020-11-10 (Rhino 6, 6.31.20315.17001, Git hash:master @ ff08c426b1ef7d3a1c50a01e5e87220a68a9f815)
License type: Educational, build 2020-11-10
License details: Cloud Zoo. In use by: eva18 ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: P330-EVA

Non-hybrid graphics.
Primary display and OpenGL: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-28-2020 (M-D-Y). OpenGL Ver: 1.1.0

Secondary graphics devices.
NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 10-22-2020 (M-D-Y).

OpenGL Settings
Safe mode: On
Use accelerated hardware modes: Off
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Unknown
Render version: (null)
Shading Language: (null)
Driver Date: 10-28-2020
Driver Version:
Maximum Texture size: n/a
Z-Buffer depth: n/a
Maximum Viewport size: n/a
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.31.20315.17001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.31.20315.17001

Hi Eva -

We’re seeing quite a few of these after a Microsoft Windows update.
I take it that this is on a desktop machine and you have one or more screens attached to it.
Would it be possible to take a picture of the backside of the computer and post that here?

Yes to all, give me a sec on the photos.

I suspect you have a monitor plugged into the back plate of the computer that connects to the Intel GPU.

Please connect both of your monitors directly to the Nvidia GPU.
You may need to use a different cable.
The Nvidia uses Display Port connections which look similar to HDMI, but only have one corner beveled.

This is a bug in the recent Windows Update.
It’s causing problems with all OpenGL based applications with discrete GPUs.

Any luck?

I tried disconnecting the monitor on the left which is shown as plugged in on the photo. Doesn’t seem to make a difference. I haven’t tried plugging the other monitor in anywhere else yet.

I switched the larger monitor to the lower input (where the other one was originally) and it works! Added the second one in next to it and rhino starts up! Thank you!

I tried installing the trial version of rhino 7 incase that might help (final crit on thursday, wasn’t keen on losing out on the time to work) but that also had the same problem. I will be uninstalling rhino 7, as I don’t think this is the best time for me to try it out. Is there anyway to start the trial period at a different time?