Rhino uses 100% of CPU every 5 minutes (and locks)


#1

If possible, I need help “urgent” to see if my problem can be reduced (perhaps with some setting or trick) I’m entrusting much of my work (more than 4 hours per day) Rhino Mac (I could not do otherwise). The problem is as follows: On average, every 5 minutes, Rhino hangs for about 10 seconds (with colored ball that spins and 100% cpu). I tried to turn off layers, close all other programs but nothing. The file I’m working on is very heavy (unfortunately I can not show it). Any advice please?

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-03-17 (506)
OS X version: Versione 10.9.2 (Build 13C64)

Plug-ins
/Library/ScriptingAdditions/SIMBL.osax/Contents/MacOS/SIMBL
/Users/xxxxxxxxx/Library/Application Support/SIMBL/Plugins/Afloat.bundle/Contents/MacOS/Afloat

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470 CPU @ 3.20GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac

USB devices
Western Digital: My Passport 0748
Wacom Co.,Ltd.: CTH-460
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Wireless Trackpad
Apple: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-8.24.9 310.40.25f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: Nessuno
Mip map filtering: Nessuno
Anisotropic filtering: Nessuno


#2

Could that be caused by Versions saving your file?
–Mitch


#3

HI. The original file is .max exported to .obj for Rhino.


#4

i think versions saves once per hour unless the user manually triggers it.
(im not 100% sure on this)


@Zsimon you can send your file directly to mcneel if there are privacy or size concerns… see the bottom of this page. (unless it’s too sensitive to share with developer even? )


#5

Shouldn’t really matter once it’s in Rhino - except of course, seeing as it’s a mesh file, it’s probably the reason why your file is “heavy”… I’m not a Mac expert, but if it’s something that’s happening at regular intervals, I suspect that it’s an autosave or the system doing something. And as autosave has been replaced by Versions in Mac, I suspected that…

The above seems to indicate that Versions saves every 5 minutes, so that corresponds to what you’re seeing. However, it claims shouldn’t influence your working, that it runs in the background. I just wonder if there is something wrong with how the Mac is set up that it uses 100% CPU (if it is indeed Versions that is causing the problem).

–Mitch


#6

Yes, I too am of the opinion that the problem can be caused by autosave (and file size). I tried to disable it but nothing has changed.


#7

Unfortunately I can not post the files or screenshots to licensing issues (regularly purchased) and privacy. The file is still “heavy.”


#8

so that’s saying you get a Versions snapshot once an hour but it Autosaves every 5 minutes…
regardless, yeah, there’s some saving going on every 5 minutes.

there’s a system wide (and possible app specific terminal method?) preference to turn off Autosave but I’m not sure if it turns off autosave while working on a document or only refers to the ‘save as’ style dialog you get when closing a window…

(personally, i keep it at default in which an application will automatically save my document upon closing… but again, i’m not sure if i turn that pref off, that autosaving every 5 minutes will stop as well… i’ll investigate some more)


#9

I made a video with a Rhino window completely empty and open monitoring activities. http://youtu.be/FsSU1j-erMc


#10

maybe try unhooking that Wacom tablet then see if you can get the same problem?
those have been known to cause issues in rhino mac performance.


#11

Already tried. No difference.


#12

hmm… i don’t know then.

i do know that i personally don’t experience this - especially with an empty document as your video shows… maybe @marlin will see something in your configuration that may be causing it…


#13

I hope to resolve soon. Thank you for your help.


(Marlin Prowell) #14

You are reporting two different “problems” here. The video is showing normal behavior of the application. The cpu usage and the memory usage are within normal parameters for Rhino.

The delay every five minutes is likely Auto Save, but without seeing the file I won’t be able to confirm that. You say the file is “heavy”, but I don’t know what you mean by that. What is the size of the 3DM file on disk? When you select all objects, what does the status line report as the number of objects selected?


#15

Sorry for my English. The model size is not as heavy as ( file 3dm 175Mb) but as the number of parts. Selecting the model in the command line at the bottom left is written: Curves 3, 294 mesh added to the selection


#16


#17

I may be wrong, but from a search, you disable autosave as you can see in the photo, if this is correct, my problem is not as autosave is disabled.


#18

i don’t think that turns off autosave… all it does is alters the behavior when closing a document… when checked as you have it, you’ll get this dialog upon closing a .3dm that you’ve altered:

in which you can revert to the point where you first opened the file and no new info will be saved…

with the preference unchecked (default), the document will close and automatically save any new data you may have added without the dialog popping up.

but-- i’m pretty sure autosave is still working in either scenario… as far as i can find so far, there’s no way to completely disable autosave in OS X for an application that is hooked up to it (such as rhino)… i do use a couple of applications which aren’t hooked up to Versions/AutoSave in which there is an app specific control for autosave (on/off or control the amount of time between autosaves)…

with those apps (sketchup being one of them), the autosave is noticeably bad and i always keep it turned off completely… with the apps tied into osx autosave, i personally haven’t encountered a problem and i welcome the feature… i very rarely lose any work in these apps. (as in- in a crash, i’ve lost an hour worth of work in sketchup on multiple occasions but with rhino, the most i’ve ever lost was a couple of minutes)


#19

Update. The blocks continue to occur. I do not think the autoasve, in fact I even block 1 time per minute. I hope to get on top of it because work in this way is frustrating.


#20

maybe try starting your computer in safe mode:

http://support.apple.com/kb/PH14204

or running rhino from a different user account…


i mean, if rhino itself was the problem, i’m pretty sure other people would be having the same ‘blocking’ problems as you are.

it sounds like something which is on your individual machine.