Rhino becomes very slow after a few minutes

There are a couple of similar topics but nothing that I found was quite the same and nothing that I tried worked.

So ever since I switched from the test version wich was also the previous version of Rhino, Rhino becomes realy slow after just a few minutes of working on any file. Often the beachbal starts spinning for several minutes even after very simple tascs like extruding a circle. It might ocoure a little more often if I type in the comand but that could also only be my imagination.
Software information

Software versions
Rhinoceros version: 5.5.1 (5F82)
Rhinoceros path: /Applications/Rhinoceros.app
IronPython version: nicht installiert
Language: de (MacOS default)
macOS version: Version 10.11.6 (Build 15G1011)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: MacBookPro5,2
Processor: Intel Core2 Duo CPU T9600 @ 2.80GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce 9400M 256 MB
Memory: 256 MB
Screen size: 1920 x 1200
Displays: Farb-LCD (133dpi 1x)

USB devices
Apple Inc.: Built-in iSight
Intenso: Slim Line
Apple, Inc.: Apple Internal Keyboard / Trackpad
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.0.51 310.90.10.05b12
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 Bit
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: Nichts
Anisotropic filtering: Nichts

Here is what I tried so far: closing every programm but rhino; restarting my comouter; totaly deinstaling Rhino and reinstaling it, which made it run fluently for about 30 minutes.

I apreciate any help. Thanks

PS: these are the files I’m currently working on

leuchte Kopie.3dm (4.7 MB)

kette.3dm (2.9 MB)

Thanks for reporting this and providing your system information.

I am curious, is there something that is preventing you from updating to a more recent version of macOS? (It may or may not be related to what you are experiencing, this is just a hunch)

Yes since my Mac is from mid 2009 I can’t update to anything past 10.11.6

I apologize, I’m not following this statement. Which version of Rhino 5 for Mac were you running before? 5.4.2? Did that work as expected? (What test version are you referring to?) I’m trying to better understand when the slowdown started to occur and under which conditions.

Yes I was running 5.4.2 before.
And by test version I mean the evaluation version
Also I forgaot to mention that I’m using the rhino educational if that makes any difference

Can you please do me a favor? Can you please run the ExportPreferences command and attach the exported file to a reply here?

Preferences.plist (26.7 KB)

Hi Lovis-

Thank you for the preferences file. Good, now we have a backup and I think I have complete information necessary to attempt to reproduce this issue on my end, which I am currently investigating.

In the meantime, if you would like to roll-back to 5.4.2, you can. Download 5.4.2 here. However, before you install it, I would recommend resetting your preferences following the Reset Rhino Preferences section on these instructions (in the middle of the page). Since you have already uploaded a copy of your preferences, we already have a backup in case this does not help.

Thanks again for reporting this and I’ll let you know if we can reproduce what you are seeing on Yosemite.

Hi again Lovis-

Unfortunately, I was unable to reproduce the behavior you are reporting on a test machine running Yosemite (with or without your preferences). I noticed you don’t have too many customizations in Rhino for Mac, so you might try running the ResetPreferences command in 5.5.1 first, before you roll-back to 5.4.2. I would do that, then restart your Mac and see if it is any better. If that does not work, I would recommend rolling back to 5.4.2 using the instructions in my previous reply above

I hope things go well,