Rhino says won't save because of invalid license, despite my license being valid

unhandled
licensevalidation

#1

In the middle of a worksession Rhino said autosave is off because license is invalid. File won’t save either, same reason given. I’ve had Rhino for 4 years, one user, one computer, no upgrades, no system changes. Why do I need to revalidate? I’ve read some forums and tried the _ValidateLicense command, says unknown. Also, through Help/AboutRhinoceros I revalidated (or reregistered?), but file still won’t save. I can’t exit without saving because I’ll lose the work. So Rhino has been running for 20 hours and any work I do on the file will be lost, so totally stuck. Any help please to save work and move on?


(David Cockey) #2

Do you have an “educational”, “commercial” or “corporate” license?


#3

no, its a regular “civilian” license, the type that doesn’t expire.


(David Cockey) #4

At the top of the screen what does it say next to Rhino 5.0?


#5

Well, I can’t see the Rhino 5.0 sign: It’s another quirk I’ve had for awhile, only in Rhino the window is oversized so the top strip that includes the minimize/maximize/close etc buttons is not visible, bleeds beyond my screen. To exit I use the pulldown menu and to minimize I use the Windows button. If you have a suggestion for this please advise. Only happens with Rhino, all other windows function fine.

Back to the current issue, I got an email from McNeel that someone logged in from a different device (I didn’t), so guessing they pulled the license. I’ve reregistered and new drawings I can save, but the current one with all the work I can’t. What to do?


#6

@conny, what happens if you type “Title” into your command line ?

Hm, have you tied to Copy and Paste your drawing into another Rhino instance ?
_
c.


(John Brock) #7

In Rhino Options > Licenses, what does it show?
Don’t post a screenshot as it will have your serial number.
What else does it say?


#8

John Brock, I tried to open License Manager and it won’t open. (assume that’s what you mean by Rhino Options>Licenses, looked in Options didn’t find licenses).
Also tried _Title, unknown command
Won’t let me select copy and paste.
The message I get with most of the above attempts is:
“Autosave is disabled because your license of Rhino does not allow saving”

I’m tempted to exit and redo the work


(David Cockey) #9

Try typing Options on the command line, and a panel with a list should open. On that panel click on Licenses.


#10

I’ve opened the Rhino options panel a few times, looked through every line, couldn’t find an entry for Licenses anyplace. I tried both typing “options”, and selecting “Options” from the Tools pulldown menu, the same panel appears but no licenses. I have Rhino 5


(David Cockey) #11

Panel with Licenses flagged:


#12

I don’t see it under libraries


(David Cockey) #13

Looks like you have a different version of Rhino V5 than I do. I purchased and downloaded my copy directly from McNeel.


(David Cockey) #14

If you type AboutRhino in the command line, or click on About Rhino in the Help drop down list, what do you see in the lower right corner above the Rhinocerous name and serial number? I see:
AboutRhino


#15

I got mine from Novedge.
Below I copied what it says at same location as yours says exactly:

Version 5.0 (64 bit)
22-May-2017
Commercial

Below that is my name and serial number