Rhino require a license to run (Rhino 8)

I get this error after I restart computer and try to open Rhino

image

I tried uninstall and reinstall Rhino 8 (The latest version) for several times, and I don’t even get a chance to log into my account. I got this window pump up immediately after opening Rhino.

Then I tried log into Rhino on another machine with my account, it works.
I also tried my Laptop with the same account. It still works, so I guess it’s not an account issue?

But I couldn’t figure out what local issue I have on this specific machine (the one doesn’t work). The only thing I did on this machine is deleting the python 3.9 folder in the .rhinocode folder.

I downloaded Rhino 7 back
And I can log in.

image

This email is bounded to a license upgraded from 7 to 8.
And I can see both seats for 7 and 8 the same time in the cloud zoo managing page.
Is that where the problem is?
But I can still log into Rhino 8 with this email on other machines

Hi -
Rhino 8 SR 1 was released a few hours ago. Is that the version you have downloaded and installed or are you running an older version?

Just in case something else was accidentally deleted - uninstalling-reinstalling typically doesn’t do much of anything. I’d try doing a “Repair” from the Windows Control Panel.
-wim

Hi @wim I was installing the version 8.1.23325.13001 released on 11.21

Tried repairing Rhino 8 (windows>apps & features>Rhino 8>modify>Rhino 8 installer>Repair).
Still having the same issue.

You could try what @John_Brock suggests here: RHINO 7 license error - #4 by John_Brock in case you have a corrupt entry blocking the acquisition of a fresh licence.

But I would copy the folders somewhere safe before deleting the contents so you can put them back if this doesn’t help. Note that the reference to Rhino 6 folders is still correct for Rhino 8 - notwithstanding R7 and R8 having their own folders, everything goes into the R6 ones.

After deleting the files try running R8 and it should go through the process of acquiring a licence.

HTH
Jeremy

Hi @jeremy5
Thanks for your reply. I tried this in the beginning, it didn’t work.
I tried again, and still having the same error.

Never mind I guess. I’m going to reboot the whole system. Hope this gives me a fresh restart.