Can't find license Rhino V7 - 🙄

Was just using V7. Closed it to check something then tried to open it again.
Got this:


Then after cancel, this:

After checking the “I have read…” box, I clicked Options>Login
Then I get… guess what… message #1 again.

After that, I get:
em-3

I have logged out of my account and back in again, no help. V8 and V6 run fine. I will now restart my machine - which means closing all the work I have in progress and see if that helps… :angry:

So, guess what - no dice. Restarted my machine and still getting

Good thing I don’t have any real work to do… :angry:

Tried removing the licenses in C:\ProgramData\McNeel\Rhinoceros\6.0\License Manager\Licenses, that didn’t help either.

Oh, by the way, if I enter my e-mail and it goes looking for my license - it finds it!

But alas, hitting the login button gets me message #1 again.

Running a repair install doesn’t help either.

Hey Mitch -
See

-wim

OK, that worked, thanks Wim! But, WTH??? why?

That might not help much, but from RH-70564 (not visible):

This is caused by some recent changes to the version of .NET used by Rhino 8 WIP and can be triggered by connectivity issues between Rhino and Cloud Zoo.

A fix for that went into both Rhino 7 and Rhino 8 on October 12th.
Public versions after that date should be fine.
-wim

Hmm, maybe that’s in the RC that just downloaded but didn’t have a chance to install…

It doesn’t look like that. The RC appears to be from 10:36 that day while the fix went in at 15:20. So that would probably have been the 7.25 version.
-wim