Rhino renames files?

A customer says that Rhino saves 3dm files with short filenames (8.3) on some network drives.
What can that be?

Hi Charles - that sounds like a server setting. Do other applications not save 8.3 names to the same network locations?

A quick google only brought up this one…

That’s exactly the point.
Other apps don’t show this behavior.

I think it could have to do with Rhino’s save mechanism.
As far as I know a file to save is first written to another file, if successful the original gets deleted, and finally the written file will be renamed to the original filename.
That’s why I asked.

Can you provide more information on Rhino version and network type?

CC: @brian - any ideas?

Hi @Charles that sounds really weird. I’m not even sure how to begin diagnosing this problem.

What are the network drives? Are they running on Windows Server? Linux? NAS harwdare? What kind?

The effect is seen on a NAS (NetApp).
On a NAS (Synology) it works as expected, the full filename is respected.

The customer says, it worked with V5 and with early V6 versions as well.

Can you give me an idea of what “early V6 versions” mean? We have a tool we use internally to “binary search” for a build where a specific bug started happening. By doing this, we can usually figure out, within a few hours, when the change occurred that broke something. This dramatically improves our chances of fixing it.

If you’d like, I can work with the customer directly to isolate when the problem started, and, I hope, fix it.

Please PM me the customer contact information, and I’ll go from there.

Unfortunately, the customer doesn’t respond.
Which means it is solved by other means, or it was not important at all.
Or he is on vacation.

Now he answered.
Sent contact data in private @brian
Thank you!