Rhino only detects 64mb video ram


#1

Hi guys,

Currently running Rhino 5.0 on Windows 8.1 x64.

I seem to have a problem with the amount of video ram Rhino 5.0 is detecting. I am currently on a NVIDIA Quadro K1100m with 2GB of onboard ram. However Rhino says that it only detects 64mb, which is pretty frustrating (see image below).

Ive upgraded the drivers to the latest (333.11), with no change in effect. System tells me that there is 2GB of ram on there, though, so I cant figure out if I should be worried.

Thanks
Sam


#2

The fact that your driver version and date are listed as N/A says there is a problem… Have you restarted the system after upgrading the drivers?

–Mitch


#4

Thanks for the reply. Yes Ive restarted many times. Pulling my hair out now trying to get this to work. Ive uninstalled and tried many different drivers for the card as well, still always displays the same result.

  • Sam

(Mary Ann Fugier) #5

Hi Sam.
Thanks for contacting us at tech@mcneel.com.

As we discussed, this is not a Rhino problem, this is an Nvidia issue.
Currently there currently no good drivers for Quadro Nvidia K1100M and others, running under Win 8/8.1. Here’s what we know currently about the nvidia cards:

We do not know when Nvidia will update their Windows 8/8.1 drivers, but Nvidia support is aware of the problems. Going back to Windows 7 means that you have better drivers and better performance from your Nvidia card today. Nvidia makes a good card, but their drivers have been up and down this past year.

Sorry about the problems.
Sincerely,
Mary Fugier


#6

Hmm, I have the Quadro k1000m (2048MB) and I am seeing the same thing. From what I can tell my drivers are all updated to the most recent versions.

I am running Windows 7 pro sp1

It doesnt seem to affect the performance though. My computer did reasonably well in the holomark2 benchmark.


(Mary Ann Fugier) #7

Hi Wattzie,
Thanks for sending the screen captures and the details about your system.
So odd, I have never seen a NA for driver information on the OpenGL panel.

Let me copy this to developer Jeff Lasor @jeff and see if he can give us some insight.
Sincerely,
Mary Fugier


#8

I’ve solved the problem by switching back to Windows 7… works perfect now (: I guess Windows 8 + Quadro + Rhino is just a bad bad combination for now. Thanks Mary for the assistance.

I dont know what the issue with yours is though Wattzie. My card is the K1100m though not the K1000m. That screen was pretty much what I saw when I was on Windows 8. Kept telling me the driver was N.A. Hope you get this sorted out soon.

Cheers
Sam


(Jeff Lasor) #9

The way Rhino “detects” any of this stuff is through the use of the MMC and Registry keys. In some instances that information can get messed up or even exist in completely different areas or even exist in slightly different formats. Unfortunately there are no well defined function calls that can be made to get this information, it’s more of a hunt-and-peck approach. Obviously there’s a way to get the information correctly and consistently since the OS seems to be able to do it, but so far I have found no single method that works on ALL OS’ and SPs. XP was/is the worse.

That being said, it really isn’t anything to worry about. This is just text information being filled in, coming from other text information within the Registry. Most of the time it works and is consistent with what the OS says, but if/when things don’t match with the OS, it doesn’t mean that Rhino won’t use all available memory…it just means Rhino’s dialog is getting the information wrong. I realize it can be confusing, but the OpenGL settings page is primarily supposed to be used for diagnostic purposes and not for system info or validation.

I will look into why things seem to be wrong more often than not on Window 8…but for now, please don’t hang any weight or importance on the information you see in Rhino’s OpenGL settings page (other than the configurable options).

-Jeff


Why Rhino only detects 64MB of my GTX860m
#10

Not all Quadros - I am running Windows 8.0 on one workstation with a Quadro 4000 and 8.1 on another with a Quadro 2000 and don’t have any problems with either. I am using somewhat older drivers though.

–Mitch


(John Brock) #11

You’ve always been special Mitch…


#12

Interesting. Maybe its just the K1xxx series then.

Thanks for the clarification Jeff. I dont know if its just a placebo effect, but I did notice Rhino ran smoother after I switched to Windows 7 and it detected the card properly. Dont take my word for it I guess. Rhino is one of the more important programs right now for me so when the whole Windows 8 thing gets fixed maybe Ill give it another shot. However I’m more than happy to stick with Windows 7 so I’m not complaining!

Cheers
Sam


#13

Sam, did you happen to run the holomark2 benchmark on both setups? It would be interesting to see the difference between the two.


#14

Atlas no. I didnt think about it. I can try testing it now on this setup for you though! Then you can compare the two to see if you are losing a lot of performance.

-Sam


#15

Where did you download it from? Says its in beta and I cant download it anywhere.


#16

Hmm, Maybe it has expired by now. Perhaps @Holo could extend the trial for you?


#17

I am running a Dell M3800 with the K1100M on Windows 8.1 and I have the same problem. I haven’t actually noticed anything wrong until I read this thread. When Holomark2 comes available I will post the results to compare the WIN7 ones against.


#18

Same issue other system.
I am using windows 10 on my new workstation and have issues with my quadro m4000.
rhino and holomark 2 are only detecting 4gb of ram but there should be 8gb :confused: are there still the same issues with that? Or is the card new to rhino?


#19

Mitch,

do you actively not update drivers? I am an update obsessive but honestly I sometimes wonder if I am shooting myself in the foot.


#20

he he :slight_smile: , actually i deal the same way with updates as you are doing, i always go for the latest updates. Got the workstation and card on friday, first i tried the delivered drivers but it was the same like the latest drivers which i updated today. My hope, this issue will disappear since nvidia set the date for launching the card officially to october. maybe it’s still to early


#21

Hi,

Same here.
Bought a new Dell Precision M3800.

  • Installed windows 8.1

  • Installed newest nvidia driver

  • Rhino options:
    -Total Video Memory 64mb
    -Driver Date NA
    -Driver Version NA
    -64mb (newest video driver)

  • Ran Holomark2 (forgot to save the screenshot) with a Total Score:
    22238

  • Installed windows 7 again: