Rhino only detects 64mb video ram

Upgrade to windows 10 incl. nvidia drivers for win10:

anyone experiancing the same issues?

Win7 seams to be the best option for now…

Hi @jeff , I contacted NVIDIA support and this is the copy of the chat (sorry for the long post):

Zia: Hi, my name is Zia. How may I help you?
Thomas Brandwijk: Hi, I have a Quadro K1100 (notebook) and windows 10. I just installed the latest drivers, but I measure a significant difference between win7 and win 10.
In Rhinoceros 3d, win10, it looks like the card is not reconised.
Zia: I apologize for the inconvenience caused and I’ll do my best to assist with the issue
Zia: Do you have NVIDIA control panel installed?
Thomas Brandwijk: yes
Thomas Brandwijk: I will send you the screenshots:
Zia: NOTE: Please select Custom (Advanced) while installing the graphics drivers and on the next screen please place a check mark on perform a clean install
File attachment upload has started.
The file win7.png (164.26KB) was received.
File attachment upload has started.
The file win10.png (159.8KB) was received.
Thomas Brandwijk: Yes, I did that
Zia: Please go to NVIDIA control panel->system information->display->save the file and send it to me.
Thomas Brandwijk: in the attached files the system info is also visible
Thomas Brandwijk: I will send it
File attachment upload has started.
The file win7b.png (302.8KB) was received.
File attachment upload has started.
The file win10b.png (225.37KB) was received.
Zia: I need the system information file from NVIDIA control panel
File attachment upload has started.
The file NVIDIA System Information 10-13-2015 16-04-49.txt (3.86KB) was received.
Zia: Thank you for the attachment
Zia: Please open settings->updates and security->check for window updates send me the screen shot
File attachment upload has started.
The file unnamed.png (1014.91KB) was received.
Zia: Thank you for the screen shot
Zia: I see that some updates are pending to install so install all the updates then restart the computer then follow the below steps
Zia: a) Open NVIDIA Control Panel --> Manage 3D settings.
b) Go to Program Settings tab.
c) Add the file you launch the program from by clicking on Add button.
d) In the setting window, change the ‘Power Management Mode’ to ‘Prefer Maximum Performance’.
e) Run the program and check.

NOTE: If you are unable to locate the .exe file, you can right click on shortcut and go to properties. Select Open File location.
Imgur

Also below settings as well:
. Vertical sync- Off
. Threaded optimization - off
. Triple buffering – off

Please set to these settings and click on apply.
Zia: Did you check?
Thomas Brandwijk: almost
Zia: OK
Thomas Brandwijk: yes
Thomas Brandwijk: I already did change the settings for all programs to: Workstation App - Dynamic streaming
Zia: Did you install the window updates as well?
Thomas Brandwijk: and maximum performance
Thomas Brandwijk: yep
Thomas Brandwijk: other users experience the same problem (rhinoceros forum)
Zia: Is the application is optimized for window 10?
Thomas Brandwijk: jep
Thomas Brandwijk: in the two screenshots I send, you see the difference of the video and driver information
Zia: Yes
Thomas Brandwijk: win7- 2gb total video memory
Thomas Brandwijk: win10- 64mb
Thomas Brandwijk: also Driver Date: NA
Thomas Brandwijk: en version
Zia: Please try with the below driver : http://www.nvidia.com/download/driverResults.aspx/92522/en-us

NOTE: Please select Custom (Advanced) while installing the graphics drivers and on the next screen please place a check mark on perform a clean install
Thomas Brandwijk: I will try, downloading: 6min remaining
Zia: Ok
Thomas Brandwijk: installing
Zia: ok
Thomas Brandwijk: shall I reboot? (this chat is on another pc)
Zia: yes please
File attachment upload has started.
The file NVIDIA System Information 10-13-2015 16-37-36.txt (3.86KB) was received.
File attachment upload has started.
The file unnamed (1).png (452.82KB) was received.
File attachment upload has started.
The file unnamed (2).png (352.43KB) was received.
Zia: Did you add the app in program settings?
Thomas Brandwijk: yes
Thomas Brandwijk: I also tried the setting: OpenGL rendering GPU to Quadro K1100
Zia: You will have to contact application developer to check with them as the application is made for window 10 or not
Thomas Brandwijk: I allready did and it does support windows 10
Zia: But its not working with window 10 as the same card was working in window 7, you will have to check for patches or pluggin for the application
Thomas Brandwijk: Ok

NVIDIA System Information 10-13-2015 16-37-36.txt (3.9 KB)

It looks like NVidia punted on this one:

“Zia: You will have to contact application developer to check with them as the application is made for window 10 or not
Thomas Brandwijk: I allready did and it does support windows 10
Zia: But its not working with window 10 as the same card was working in window 7, you will have to check for patches or pluggin for the application
Thomas Brandwijk: Ok”

The tech ended the conversation by stating the exact problem for which you contacted them. I think he/she missed the point of the conversation. Zia says “But its not working with window 10 as the same card was working in window 7”. …and I would say that technically that’s not accurate. The more accurate statement should have been:

“The speed of the application is slower in Windows 10 than it is in Windows 7 using the exact same card.” … Why?

…the application is working just fine and there is no patch or fix that can be applied that’s going to resolve this on Rhino’s end. The good news is that you’re using a Quadro card in your case…which means I can contact NVidia directly and get them to look at this and hopefully figure it out.

As for Rhino’s OpenGL settings page not showing the correct information… That has absolutely nothing to do with whether or not things are working with the display pipeline, or whether things are going to run slower or faster. All of the information below the “Shading Language” entry is gotten by digging through the Registry and not through any kind of OpenGL usage, so it’s not any kind of indicator of whether or not Rhino is “using” OpenGL correctly or even if “Rhino is working correctly”. You’ll notice Holomark is reporting the same (correct) information in both your cases, and yet the results are different.

If your scenes look right, if shadows, lighting and materials are displaying correctly, if wires and annotations look correct…etc…etc… then everything is working just fine. If things aren’t running the same speed, then there’s really nothing I/we can do about it…it’s some bottleneck somewhere that is now occurring between Rhino and NVidia within Windows 10.

Having said that… You’re also using a 3rd party, scripted mechanism written for Rhino to test benchmarks, and although I agree it’s a great tool, it’s not a true hardware benchmark and can be subject to all kinds of differences that can exist between different OS’ and configurations. In other words, your results are actually that Holomark is running slower on Windows 10 than in Windows 7… Now, could it be that it’s because OpenGL is running slower? Quite possibly…but not definitely. Unfortunately, you can’t easily go back and forth between Windows 7 and Windows 10 to try other things, and you’re currently only left with one snapshot you took when you had Windows 7 installed.

The only thing I can do for now is bring this to NVidia’s attention (specifically, the Quadro folks) and see what they say.

Finally… Rhino’s OpenGL Settings Page is not a diagnostic tool. Please do not rely on its contents as some kind of indicator of whether or not Rhino’s display pipeline is functioning properly. The options are there to help optimize specific settings for specific configurations, but the rest of the information on the page is only placed there for tech support purposes…and if the information is wrong, oh well. Sending screenshots of it to people like NVidia is only going to get them to immediately think there’s something wrong with Rhino and punt. Now I agree it’s a bug in Rhino, but again, it’s a bug that has no impact whatsoever on whether or not Rhino’s display and OpenGL usage is working correctly.

Thanks,
​-Jeff

Please update us when you hear more on this, thanks.

I’m update, because i see an indicator for false results !!!

  1. Total score 25675 with 64 MB GPU ??? —> That can not be never true !!!
  2. CPU score between W7 (13027) and W10 (8535) is different !!!
    So it shows more of a problem between the Motherboard <-> Chipset(Driver) <-> OS
    or
    General problem between Older Software Programing API and New OS

So, you think it’s a Dell problem?
I have updated de chipset drivers, but I will submit the problem to Dell support and let you know!

I also have a M3800 machine (Windows 8.1), and have the same issue. Hope that any fixes can solve this issue for both Windows 8 and 10

For reference: My Holomark 2 score was 23,114

Regarding the nVidia drivers, Dell’s website has them last updated in February 2015.

Finally, with the limited video memory, would this affect shadow quality (not viewport performance, but specifically quality)?

Hi Thomas

I think Rhino was not even start properly with FHD screen and 64MB GPU, and thus no score will be calculated with 25675 points !

A question:

What is calculated in W7 and W8 or W10 under “Performance Information and Tools” (windows system rating), is here a different result ?

Or what says Cinebench -> http://www.maxon.net/products/cinebench/overview.html

Just an idea to help you bugtrack:
Have you checked the bios? It could be a setting there to simulate or compensate for some old xp bug that windows 10 is wrongly interpreting. Obviously the machine uses more than the 64 MB, but the CPU scores tells me something is wrong. Again it could be a bios thing. Many computers ago I got 2X the graphic performance in Rhino by updating the system bios. (the old bios had a bottleneck/bug).

And it could be a chipset driver thing.

Good luck!

Anyone with a M3800 tried the latest BIOS chipset (A09)?

The latest is A10, but I didn’t tested it jet with windows 10 because I was done with switching between opperating systems…

Hi all

It is 2016 and this problem still exists. Does anyone know the solution ??
I have updated to window 10 as well as the latest video driver, the
driver date in openGL just appears as N/A , which is really frustrating.

Anthony

On my workstation I had different issues after updating to W10 due to tons of old W7 stuff that wasn’t 100% compatible.
So I did a clean install of W10, and that cleared out the small bugs for me. I am not saying this is your case, but upgrading OS’s can cause issues that the preinstalled software and or drivers can not identify.
In example Acronis True Image was one of those tools that tagged along and appeared to work fine on the upgrade, but it will not install on the cleaninstall of W10. So similar stuff can happen to drivers, have you tried to use a driver uninstaller like Guru3D’s Display Driver Uninstaller?


Also delete all driver folders, so they don’t autoinstall back in on the first reboot.
Then reboot one or two times, and then download and install the fresh drivers and reboot again.
Good luck.

Thx a lot for your reply, Although I have downloaded the driver installer and operated a clean install, I try to uninstall the current display driver.

I updated my drivers on Friday and started Rhino and saw the date displayed as N/A. I shut down and when I started Rhino the day after, it reported everything correctly.

Also note that Rhino tries to find the driver information but that it doesn’t necessarily succeeds. That doesn’t mean that the driver is not working correctly.

I am using Windows 7 64bit with A Quadro M4000 with 8gigs memory on the videocard. OpenGL setting always showed 4095MB memory. This a machine I just built specifically for Rhino and have the latest drivers and minimal extras installed. Just Netfab, Neon and Acronis for backup and Firefox and Chrome for the internet. Though the Quadro seems to work fine since the second version of the drivers for the M series ( when I had artifacts trailing highlighted objects when spinning a model in Rhino), it’s reassuring that the info in OpenGL settings is just that, “info from text” and not necessarily physically true. My question is…Do you recommend updating to Windows 10, something I’m still on the fence about?

Any solutions about it? I have the same problem here.

This is logged as https://mcneel.myjetbrains.com/youtrack/issue/RH-38996

It is 8th of May 2017 and I just updated my K1100M drivers to version 382.05 on Windows 10 and ever since I was trying to figure out why my Rhino is blurry and just literally painful for eyes to look at now. I think I have the same problem since my Rhino says NA in the OpenGl DriverDate and Version. I tried to re-install Rhino, re-install drivers, update Windows, changed settings in NVIDIA control panel. Nothing worked. Please help! I have a dead-line next weekend, would appreciate the response as soon as possible.

Did you also just install the SR14 update for Rhino?

The bug referenced above is only in the reporting to the dialog. Rhino still is using all of the VRAM that Windows sees. It will not be fixed until V6 as it does not effect performance or usability.

The symptoms you describe sound much more to me like the problem a few people are seeing with the recent SR14 update.