Open GL problem in SR10

i would like to solve problem with my video card in new service release. In older versions, i had active hardware accelerator of my video card (Nvidia NVS4200 - notebook ver.) and “everything” was ok. shaded views works etc. But after update, rhino can’t recognize my video card (my driver is up to date), so i have no chance to turn it on with command hardware acceleration in open gl file.

So what should i do with this issue? I would like to use my video card at full power. It is interesting, that on 32bit Rhino version, which i have not updated, everything works.

Thank for all replies

Hi Petr- I think I’d re-install/update the drivers to see if that kicks it in - please let us know if that does anything useful…


Hi Pascal,
i have tried to re-install my video card driver. It doesn!t help. It’s weird, that older version (32bit) works, but updated Rhino on SR 10 doesn’t. Could problem be in Rhino and this service release?


There are a number of potential problems here. To fix it, we will need to know a bit more about your hardware setup.

I can see from your screenshots you have both a Nvidia card and an Intel HD card in the Laptop. This combination makes it much more complicated when trying to update drivers and getting Rhino to recognize the correct card.

What model of laptop do you have?
Which operating system are you running?
Are you running in a virtual environment (Vmware, Fusion, etc…?)

From this information, we can start the process of updating. Generally the steps are to update the Intel drivers, then update the Nividia drivers manually. Then we will set the system to use the High Performance video. But with the information above, I can be more specific.

I think there is an important option to do a “Clean” install which completely removes the old before installing the new drivers.

You have a dual graphiccard laptop so go into nVidia drivers and check that Rhino is sat to use the Quadro. This can be a problem with dual graphiccards.

From Google:

From NVIDIA Control Panel:
3D Settings-> Manage 3D settings
The Tab "Preferred graphics processor " , select
High performance NVidia processor

It looks like that is a general tab, but you should be able to do the same for each program that has a profile. And maybe you need to add Rhino if it doesn’t have a profile allready.

Hi John,
yes, i chose this option, when I was installing new update of my video card drivers. It didn’t help…

Hi Holo and Scott
yep that’s right. I have dual graphiccard laptop. This issue what are you talking about… i have solved it a long time ago. Here is a screenshot of my setting of my NVIDIA…
Sorry for the czech language.

My Laptop model Lenovo T520
working with WIN 7 64 bit
and nope, i am not running in virtual enviroment…

Look at this

it’s weird, that my problem is just with SR10 64 bit Rhino, but SR7 in 32bit Rhino works normally.

@Jeff he seems to be right, there must be a bug in SR 10 OpenGL.

Holomark2 illustration mode looks like this now:

Somehow all directions are flipped. If I flipp the surfaces so they point the wrong way then it looks like this:

But as you can see I can not flip the “holomark” name as it is a solid, so it refuses to be inside-out.


I also tried to install update new drivers for integrate video card, but i something is wrong with it. My laptop does not allow me it…weird. So i am still running on old driver from 2011…damn

Jorgen, can you please export this display mode and post it here…

I have no idea what would be causing this in SR10 that would be specific to a display mode or a display mode setting. If your normals are reversed in one mode, then they should also be reversed in every mode…

What does it look like if you turn ON backface coloring and select an visually obvious color for all back faces (i.e. bright pink) for something like “Shaded” mode?


Never mind…I’m seeing it here too now using your Holomark modes… It looks like something isn’t working right related to back face settings and culling. There was a change to the way that state was tracked due to the differences between GeForce and Quadro cards having to do with double sided lighting and performance differences (remember?).

It definitely looks like something broke…ugh… this is really bad news and now I need to explain why it looks like we’ll need an SR11.

I’ll keep you posted… However, this problem has nothing to do with the original problem in this post…not sure why you think they’re related… Can you please explain why you think this has anything to do with what Petumatr posted initially. ???


Hi Jeff,

so do you think, there is something wrong with SR10? As I wrote, there was everything ok in SR9. After update - unsolvable problem for me right now…


Hi @Holo @jeff

The mini surfaces do the same thing in Holomark2 test when running the GTX 980M too the other day…

Looking at the info on my system, I’m running SR10 - oops, hadn’t noticed sorry guys

Yes, it appears that something was broken…I’ll know more later, after I’ve dug into it some more.


I see the problem. I think you may need to re-install the 3 critical drivers for the video system:

  1. The Intel HD video driver
  2. The Nvidia Optimus Driver
  3. The Nvidia NVS 4200M driver

I expect one of these three is not completely updated. You may consider uninstalling these 3 drivers off Windows. Then re-installing from downloaded version off the Lenovo and Nvidia websites. I have seen this confusion between drivers before in these dual card configurations.

However, I’d like to clarify that the problem I’m talking about is NOT the one that’s actually being discussed in this thread.

Oh, it was not thinking logically at all, other than a “one thing isn’t working in SR10, and an other thing isn’t working, so maybe they were related”., and it reminded me to post.

I first noticed it on an old machine that I had installed the GTX260 card and had a test version of Windows 10 running, so I thought it was the drivers there, or the card, that messed up so I paid no attention to it. But then I saw it on my workstation too, but was to busy to post about it then, and then I forgot all about it. It was a busy week.

((And yes, I remember the double sided geforce issue, the memory is working again now! :slight_smile: )

@holo Well this is looking more like a very specific case (which means it’s probably going to be harder to force any kind of SR update)… This only happens when you have a Technical mode configured to use shaded surfaces AND rendering materials AND there are transparent materials used AND those materials are applied in an order that causes the problem… I realize that’s pretty easy to do once you’ve created that type of display mode, but I’m not too sure how often that occurs.

Now, I realize that your Holomark creates just such a mode, and that many users are using Holomark, and your test case then creates the situation that shows the problem so it could be viewed as a widespread problem… so that will definitely need to be taken into consideration.

I’ve fixed the problem and it’s sitting in the V5 source tree…I’m just not sure if it will warrant any kind of update.

In the mean time, you can get things working again if you change your illustration mode to use something other than “Use front face settings” or “Rendering Material” for the Backface settings field… If you use any of other possible values for that setting, then things will work…so you might want to consider updating Holomark’s display mode until we can get this figured out.

BTW: Huge thanks for finding this! Apparently Holomark is the only test so far that revealed the problem…I only wish we/I ran it prior to releasing SR10.



Is the camera also dropping below the plinth in the error too? I hadn’t noticed it on the Mac but it seems to now. It’s a little jumpy as there are a few other things running in the background.