Rhino keeps freezing in Windows 10


#1

Hi everyone,

I am an experienced user of Rhino, but I got a problem since I have switched my OS to Windows 10. My Rhino 5 goes “Not Responding” randomly while I am panning or rotating the perspective viewport. It happens even without any objects in a newly opened file. It could happen just seconds after starting the application. My guess is that it should not relate to auto-saving. The app wont come back and the only option is to force close it. Only Rhino freezes while windows 10 is working normally.

I clean installed my Windows 10 and Rhino 5. I had my driver updated. It happens to my desktop, which has an i7 CPU and nvidia GPU, as well as my Surface Pro 4, which has an i5 GPU and integrated graphics.

I now literally cant use the software to do modelling. Could anyone offer help?

Thanks,
Norris


#2

Just a quick stab in the dark here: Could it be related to the fact that Windows update supersedes drivers you know work with it’s own ideas of what you need? I’m not on 10, but have read that this is one of the big annoyances of 10 for folks who need specific driver versions for happiness.


#3

I can’t offer help but I’m having the same issue in Chrome (?!) and Maya, but not Rhino (yet?). I’ve been searching for a fix for days and haven’t come up with anything yet. i7 6700k, Quadro K5000 for me. I’ve tried many old drivers and disabling GPU support entirely, so far nothing. It may not be GPU driver realted although it certainly feels that way.


#4

I did an windows 7 -> windows 10 upgrade on my workstation and had similar issues, it was also difficult to uninstall old software, and I had bunch of old software, then w10 crashed and could not be repaired so it reverted to W7… so I decided to upgrade again, but still it was a bit buggy, so after a while I did a clean install of W10 to start fresh, and since then it’s been smooth sailing.

You can try to do a manual clean uninstall of the nVidia drivers, and at least use the advanced option in the driver installer to do a “clean install” from there, but that does not remove everything as well as Guru3D’s driver uninstaller:

Good luck.


#5

About WIN 10 myself experience.

I have to confess. At the First i was surprising with the new OS Win 10 PRO x64. But after a while on working with softwares that require OpenGL algorithm i found big issues and a very unstable OS to have a nice workflow.

I found that the possible main reason for Win10 wont work properly is due the fact that all people u have GPU card from fabric for work under DIRECT X 10 and 11, the new OS 10 will replace that old DirectX properties with an image emulation for working under Windows 10. (i think this was Microsoft intent to push all users for their new OS)

So, all that GPU cards need to work under a not native software emulation that will causes buggy issues, specially under Rhino, CAD, SKetchup, Artlantis, PHOTOSHOP, ILLUSTRATOR, INDesign and so on. (mostly my work softwares).

I have experienced the same frustrations.
The very first was when i upgrade my Win7 to Win10 under the Microsoft automatic upgrade… Result in all messed up and unstable OS.

Second… i test a fresh and clean installation, from BIOS, of Win10… results in better performance, small gaps, and small issues. But in fact, all OpenGL softwares start to crash after an hour on work.

Third… I have to get back to what i found the best reliable and stable Windows OS - Windows 7 x64 -
I was able to get the work flow that i miss under Win10. I was able to work without bugs, crash or any kind of issues.

…What i try to mean is… Win 7, for now, still is the best Microsoft OS which show better stable performance… I think we only need to go forward if we buy new hardware components, specially prepared for new requirements, DIRECTX 12 and so on. And still wait for all new software stable versions which will work specially under Windows 10.

Windows 10 is to young for now. But i think it will be the one of the best Microsoft OS.

best regards.


#6

AIW,

I guess you hit the problem. You reminded me that there was a period of normal working right after the clean installation of windows 10. Windows updates might have caused the problem.

Holo,

I have tried using the advanced option in the driver installer to do the “clean install” before. It worked out for a day or two, but soon reverted to the problematic state. I have suspected that it is Windows update who caused the issue. But I soon dropped the idea having no support. I tried “clean install” just now. And it is working normally again. However, if AIW is right, the underlying cause could be the fact that the correct driver is replaced every time Windows update starts.

I don’t know if there is a permanent fix. At least I now know I should do a “clean install” every time after a windows update which I can’t stop. Thanks.

Norris


#7

Wow, guys; I guess I’m the lucky one; no problems after migrating from 7 to 8.1 then to 10. That was the progression that took place out of simple chronology, not all in single day. Point is, everything is smooth and stable. And, I’ve got 10 looking just like 7 sans some of the less than useful Aero features. Core I7 3930K overclocked to 4.25 ghz on two rads, Raid 0 Samsung 480 gb C drive, two mech hard drives one of which is cloned daily the other of which is backup weekly. Monster Cooler-master Cosmos II case that also is big enough to heat my breakfast…anyway, the system is far more stable than my health. Cheers, Rob


#8

As I alluded to, this has been a well-discussed issue with Win 10, and some of the articles I read discussed methods to surmount the problem. I’d suggest googling or binging something like “Windows 10 automatic driver updating problem”. It would also probably be a good idea to take note of what the driver versions are that work, then check (if you get zapped again) what they are after Windows Upgrade gets done working you over just to confirm that’s what’s going on. I would most suspect the video driver, but I suppose it could be any of them.


(Miled Rizk) #9

I know it’s an old post, but I had the same problem with my Sony Vaio laptop.
at the end, and after few days of frustration, I solved it by going to: File, Properties, Rhino Options, View, OpenGL,
and check the option: Do Not Use OpenGL For Drawing Feedback Items.
I also made a video on YouTube for people who may have the same problem: https://youtu.be/VnhB1rou-gI


#10

similar issue for me as well. But Rhino isn’t the only program that freezes. I would be in the middle of drawing a line, or just moving my mouse where suddenly everything freezes. after 10-20 seconds, my sound also goes off. and the only way is a force shut down. Today alone this happened to me 7-8 times. It all started when I upgraded to windows 10 last week.


#11

Do you know the GPU driver version?


#12

i have 22.21.13.8601 for the k5000


(John Brock) #13

Do ou have V-Ray 3 loaded?


#14

http://www.nvidia.com/download/driverResults.aspx/126585/en-us
Maybe reinstalling latest driver may help…


#15

I do have v-ray 3. It all started 2 weeks ago with my computer getting really slow in shaded view when working on a specific file (compiled of multiple blocks). In the same week, I also upgraded from windows 8 to 10, and that’s when the crashes started as well. over the weekend I did a complete re-install of everything, including v-ray 3. also added more ram, and a second K5000. but the crashes continued. yesterday I did another re-install of windows 10 while keeping all the apps and files intact, but that didn’t fix itself. when the computer crashes, everything stops responding. but when I’m not running rhino, there hasn’t been any crashes so far. For now my only thought is to downgrade back to windows 8.


(John Brock) #16

@shamimsz

No.
Read the link!
In Options > Plug-ins, disable V-Ray and restart Rhino.
I suspect the problem will go away.

Then you will know.


#17

@Miled_Rizk I recently purchased Rhino 6 (installed on Windows 10) and I am experiencing the same problem you described in your video. I tried your fix, but Rhino 6 does not have the option “Do Not Use OpenGL For Drawing Feedback Items” under the OpenGL menu any longer. Do you (or anyone else) know if this option is still available in Rhino 6 and if so, where is it located within the menu? Thanks!


#18

While the symptoms might seem to be similar, the display code in Rhino 6 is completely different from the one in Rhino 5 and so the problem is not the same.
Please run the Rhino SystemInfo command and paste the result in an answer here.


#19

King [System Info]


#20

I would start by updating the drivers to the current version.