Rhino not using GPU

Hi Steve,
I have a Rhino V7 license that now is out but Run without inconvenient with my system…


System Information.:
Rhino 7 SR34 2023-9-24 (Rhino 7, 7.34.23267.11001, Git hash:master @ a37d83041828484840f2448d5b3e3770e46694f9)
License type: Evaluation, build 2023-09-24
License details: Stand-Alone
Expires on: 2023-02-27

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 7.8Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y). OpenGL Ver: 1.1.0
> Integrated graphics device with 2 adapter port(s)
- Windows Main Display attached to adapter port 0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 0.0 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Microsoft Corporation
Render version: 0.0
Shading Language: Not supported
Driver Date: 5-19-2016
Driver Version: 9.17.10.4459
Maximum Texture size: 1024 x 1024
Z-Buffer depth: 32 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2172 MB

Rhino plugins that do not ship with Rhino
C:\Program Files\Orca3D V3\Orca3D.rhp “Orca3D” 3.0.10.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.34.23267.11001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.34.23267.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.34.23267.11001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.34.23267.11001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.34.23267.11001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\GIOVANNI\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\SectionTools\2021.4.30.511\SectionTools.rhp “SectionTools”

If you note in the web the two version needs the same system requirement…

image

image

image

So, Why RhinoV7 run ok and RhinoV8 Run with some restriction like Hatch and lines type only in Wireframe into Window pipeline and not Open GL.

Wireframe View Window Pipeline:

Wireframe View OpenGL Pipeline:

Regards,

This is a confusing SystemInfo as it is reporting that the GPU is detected, but the OpenGL level supported by the GPU is below any level I have ever seen with Windows 10. Rhino is not using the GPU at all in this case and is using a very basic implementation of OpenGL that Microsoft provides with Windows.

Can you post a screenshot of your OpenGL settings page in Rhino?

Thanks Steve,

Here is the screen pic of Rhino V7:

Here is the Screen Pic of Rhino V8:

@jeff do you have any ideas of things to try? It doesn’t look like Rhino sees a GPU at all

Mmmm, I do no.
V7 with Pipeline OpenGL the hatches and line-type run all view perfect, but RinoV8 doesn’t. Only with Wireframe view with Pipeline Window…
So, What is the problem?

You might try setting the Opengl level to 1.1 (move the slider to the left a few steps)

Also you should probably click on the box that says “GPU Tessellation” and turn that off.

2016… It might be time for an upgrade of that driver. I’m surprised that R7 runs, but not surprised that V8 isn’t. Also, 2GB VRAM is well below recommended spec, but with an updated driver it could (probably) work.
HTH, Jakob

Jim
I unchecked GPU Tessellation.Same behavior in Render View.
I am waiting for Steve & Jeff answer.
Thanks

Jakob,
If the System requirement are the same so the two version must run ok…
I don’t like easy answer like Pascal. I do like concrete answer.
Thanks.

That is not correct in any sense.

Your computer is below spec for 7 or 8(or 6 for that matter, Intel Integrated Video is simply not fit-for-purpose,) you are running it “at your own risk,” and drivers must be kept up-to-date.

I don’t feel the same way.
I have passed my V7 trial period with no problems. I look forward to hearing from Steve & Jeff. They are people who want to help and may give me a concrete solution. They, only they, will tell me the final word.
Thanks anyway.

Moving the slider back and forth or unchecking GPU tessellation will not make any difference in this case. Make sure the slider is all the way to the right and this checkbox is checked. Those controls only have the ability to change how Rhino works when Rhino is actually working with a GPU.

The Microsoft driver report is the problem. There is something going on where Rhino is not able to use your Intel GPU and is resorting to a very old software based implementation of OpenGL. This is essentially Rhino attempting to run without a GPU at all which is not what the program was designed for.

Updating the Intel GPU driver is a good thing to try first if an update even exists.

I don’t understand at the moment why Rhino (neither V7 or V8) is not using the Intel GPU… My current guess as to why V7 works “better” than V8 is that V8 may be making certain assumptions about GL versions that V7 does not…or vice versa.

That being said, the only case I can come up with as to why there is no OpenGL available on your system is because there is no specific ICD OpenGL driver installed… The default drivers provided by Windows/MS, do not necessarily install with OpenGL support… Thus, updating your driver is actually my first recommendation…assuming there is an update available.

Once we can get OpenGL working on your system, we can then start trying to isolate why certain things aren’t working.

Note: Rhino does not “choose” to use specific GPUs or drivers…that’s all done by the OS (Windows)… So if Rhino is not reporting OpenGL usage available, then it’s because Windows is not loading an OpenGL compliant driver when it starts up Rhino.

Thanks,
-Jeff

Since your PC doesn’t even meet the minimum requirements for R7, I’d say you’ve just been lucky up until now. A lot of things have changed under the hood between R7 and R8; it’s not just adding tools and changes to the UI. And keeping your graphics card driver up-to-date is something you need to do even without new releases (even just service releases) as Window updates wilæ sometimes mess up drivers.
-Jakob

Hi Steve,
I check using the intel tool “Intel-driver-Support-Assistant”… Is ok. If you like I send to your and Jeff by e-mail the report.
Thanks for the effort!

Hi Jeff,
I send a message with the Intel report to you and Steve.
Hopefully you can discover the hidden secret of why it works well in V7 and not V8.
Thanks!!

Hi Jeff,
Thanks for your post.
Here is the real Open GL that have my machine:

The strange thing is that the information provided by Rhino V7 and V8 is from OpenGL 1.1… As you have observed in the previous images.

I’m curious that Intel HD Graphics 2000 works as well as it has been on Windows 10, given that Intel don’t support that combination (HD 2000 + W10).

That doesn’t solve the issue here, but I’d be suprised if there was even a driver to which they could update.

Infact, it seems that 9.17.10.4459 is potentially for Intel Graphics HD 3000. If this isn’t a Rhinoism, you may even need to consider rolling back to a different driver. Maybe that will correct the reporting?

The last official EOL driver for this particlar iGPU is 15.28.24.4229 (9.17.10.4229). Unless you have some arbitrary Microsoft one that’s been sat there since purchase.

I’m very surprised to see a computer with this configuration as well running Windows 10. Now I understand why there are no driver updates available. The HD2000 is not going to be able to operate correctly with Rhino 7 or Rhino 8 even if we were able to get Rhino to recognize the GPU.

Rhino 8 assumes you have a working GPU which is why some things like linetypes and hatches are not appearing. We have built in fallbacks over the years to support situations where lower level OpenGL is needed to be used. Linetypes and hatches were rewritten with regards to display in Rhino 8 and we would need to add fallbacks to try and get geometry like this to show up on your screen.

I hate myself saying this, given my contribution in another topic, but I think it is defensible here. If Rhino will allow it, and this somewhat strange combination is working (a 2011 Intel i3-2nd gen with Windows 10!!!), I’d drop onto Ebay or whatever and buy myself out of the problem.

Any old and functional nvidia 10 series (GT 1030, GTX 1080) may permit an escape to this. Even a GTX 1050 or a 1080. They are practically e-waste now. A GTX 1050 doesn’t even need a power cable.