Rhino not opening files

Rhino isn’t opening files as is instead going to ‘Not Responding’ I’ve tried waiting half an hour and still no luck. I know they should open on my PC because I made them on it. What can I do to increase the chances of them opening? I have a deadline in the morning :frowning:

Hello - Please also run SystemInfo in Rhino and post the results here… then can you please try starting Rhino in safe mode and then open the files? Does that work?

Start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.

-Pascal

No it doesn’t open in Safe Mode

Here’s the System Info:

'Rhino 6 SR13 2019-2-27 (Rhino 6, 6.13.19058.371, Git hash:master @ 17cd8b51accbe17dd04b48028f49d5e77a67f17b)
License type: Educational, build 2019-02-27
License details: Cloud Zoo. In use by: Callum Woodford ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-3CC4MTH

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 8-15-2018 (M-D-Y).
Primary OpenGL: NVIDIA Quadro M1000M (NVidia) Memory: 2GB, Driver date: 3-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.67

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2019
Driver Version: 25.21.14.1967
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros 6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\callu\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.12.6.531\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”’

I should have specified, do not load any of the third party plug-ins (In particular VRay for now) on opening in safe mode. Another test would be to open Rhino normally to an empty file, block/disable VRay in Options> Plug-ins and then restart Rhino, then try to open your file.

Others that catch my eye are Displacement, SectionTools and NamedPositions - you might try disabling all of those and then if Rhino opens the file, re-enable one at a time to see if you can determine if a plug-in is to blame.

-Pascal

Disabled all the plugins and started in safe mode and there’s loads of writing scrolling in the command box with the writing you can

i faced the same issue today.
can you suggest the solution to this?
thank u in advance.

@callum, @ryan.jenson90 - can you please send me your settings files from

%AppData%\Roaming\McNeel\Rhinoceros\6.0\settings > settings-Scheme__Default.xml

-Pascal

settings-Scheme__Default.xml (36.2 KB)

Hi Callum - can you please, with Rhino closed, rename that settings file to

Scheme__Default_Old.xml

and then start Rhino?

-Pascal

The file still isn’t opening, no scrolling text this time though…

have you tried with _Rescue3dmfile?

So, is this one particular file that will not open?

If so, can you send us that file? (tech@mcneel.com, or www.rhino3d.com/upload, to my attention)

Please also include a link to this thread in your comments, thanks.

-Pascal

Hi Callum - your file opens here, but everything is locked - is that expected? Were you in the midst of a BlockEdit by any chance, when the file last closed?

Hm saving this file takes a very long time… I’ll see if I can figure out what is wrong

-Pascal

It was a few months ago that I last opened it so not sure - ok thanks a lot Pascal!

Hi Callum - I sent a file back via a link to our upload system - did you see that? Was it any better?

-Pascal

Received it but the file was 0 bytes

hmmm - let me try that again…

I’m uploading a zipped version now - still a large file; ~1GB

OK, I got an error message this time about the file being too large. By like 1000 bytes. Let me see what I can do to split it up.

@callum - the problem seems to be in two off layers - Foliage and Foliage 2, which contain thousands of meshes. I’m seeing if joining these into two single meshes reduces the file size enough to make it more tractable.

-Pascal

Ah I know the ones you mean, completely fine to delete those layers!

OK - Uploading again…

-Pascal

Yessss it’s working!!! Thanks Pascal you absolute legend :smiley: