Rhino Crashes opening ANY file

Running Rhino 6.29. This morning suddenly I can’t open any files. Neither from double clicking on the file or from the open command in Rhino. In fact when I even type “open” or go to the file drop down open it hangs for 45 seconds before it even allows me to open a file.

GPU drivers are current, windows is current, redownloaded Microsoft.net, and C++ redistributable, Installed Rhino 6.30 and now back down to 6.29. I’ve tried to start windows in safe mode and Rhino in safe mode. Tried disabling all plugins. Nothing makes a difference.

I can open rhino by clicking the shortcut. I drew a few lines and saved the file. That file I can open. But I can’t open any previously created file. Even ones I was using yesterday.

Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Commercial, build 2020-08-25
License details: Cloud Zoo. In use by: Chris ()

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: DESKTOP-4V2HOQ8

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Ti (NVidia) Memory: 11GB, Driver date: 9-30-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 456.71

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-30-2020
Driver Version: 27.21.14.5671
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501

Hi -

Can you post one of these files that cause a crash?
What happens when you import one of those?
-wim

I’m realizing now that it is also happening with other programs, not just Rhino. I’ve never had this happen before.

Do other programs also crash? You may need to read what the crash dump says.

Yeah it was other programs as well. Ended up rolling back windows to a previous version. Just posting for others in the future.