Rhino model has inch units but exported step file has mm units

I have a Rhino model that has inch units. However, when I export it (using the AP203 config control design) the units change to mm. For example, the height of the attached 3dm model is 4.502". However, in the step file this is 114.35. This has been verified by loading the step file into two other apps (FreeCAD and Mecway).

Why does this happen? Can I change this behavior?

Rhino_step_export_test.3dm (121.2 KB)

Rhino_step_export_test.stp (54.9 KB)

Windows 7 Pro
IMPORTANT – Rhino 2.0 (yes, very old but still satisfactory for my needs)

Don C.

It exports in Rhino 6 using Step AP203 in inches.
StepTest1.stp (56.5 KB)

There may not be anybody else on the forum with Rhino 2 available.

Hi Don -
When I import your “Rhino_step_export_test.stp” file into a millimeter document in Rhino 7, I get the following pop-up:

Perhaps you should be looking for a setting in the receiving applications?
At any rate, 4.502" is 114.35 mm and the receiving application should be able to deal with that…

What I don’t understand is this – If I create a Rhino model that is 100 mm high and save it as a step file, then importing it into FreeCAD or Mecway shows that it is 100 mm high. (The Rhino document properties show that the model units are mm.) However, if I create a Rhino model that is 100 inches high and save it as a step file, then importing it into FreeCAD or Mecway shows that it is 2540 mm high. (The Rhino document properties show that the model units are inches.)

Thus, if the Rhino model is in mm then Rhino doesn’t do any units conversion when it exports the step file. However, if the Rhino model is in inches then Rhino converts the inches into mm in the step file. I think there should be a setting in Rhino that controls this conversion. Then if I model in inches, the step file that Rhino creates would also be in inches, not mm.

As Wim, said, the issue(well I don’t know if it’s an “issue,”) is with the software you’re importing into, the STEP is in fact in inch units. I’m not really sure what the problem is, they are scaling it correctly.

For the Rhino 3dm model that was created with inch units and saved as a step file, I looked at this step file with a text editor. The CARTESIAN_POINT values show that the coordinates are actually in inches, per Rhino’s 3dm model. This means that both FreeCAD and Mecway are converting the inch step file from inches to mm (without asking) when they load it. I also tried loading it in Salome-Meca; it pops up a dialog stating that the step file has units of inches and asks if I want to convert.

I did find the following in the inch-model step file that weren’t in the mm-model step file –


FreeCAD : Changing unit system

  • Select [Edit]-[Preferences…] in menu bar to open Preferences dialog.
  • In the dialog, select [ Unit ] tab in [General] panel and set a unit system by [ Unit system ]. You can select one of following unit systems. …
  • Set the number of decimal places at [Number of decimals].
  • Click Apply to apply settings.

You can change the unit system before the import or after the import the part. I imported part to metric template, the dimensions were in mm, after changing the unit system the units are in inches - the base 2.46"×2.46" the maximum height is 4.5" and the shortest height is 3.75".