RHINO MAC latest commercial version - Import SolidWorks File .SLDPRT

It just open if you launch Rhino and do not open other files. If you already working on other files and try to open .SLDPRT rhino crashes and the only way to resolve is to terminate the application.

Hi @raffaele-

Sorry for the delayed reply. Can you provide a .SLDPART where this crash happens? If we can reproduce the crash on our end, we could likely fixed it.

Hi Dan, it happens whit every file a try to open… as I described I have the problem only if I open .sldprt file and I have some other work open… If I import as soon as I open rhino it does not crash.
Attached a very simple file.

Please let me know if you need much more information or complex file.

I use RHINO since four years ago and my experience in 3d modeling is more than 20 years.

My main experience is motorcycle helmets.

Thank you

Best Regards

(Attachment pulsante Areatore Mento.SLDPRT is missing)

Hi Dan, it happens whit every file a try to open… as I described I have the problem only if I open .sldprt file and I have some other work open… If I import as soon as I open rhino it does not crash.
Attached a very simple file.

Please let me know if you need much more information or complex file.

I use RHINO since four years ago and my experience in 3d modeling is more than 20 years.

My main experience is motorcycle helmets.

Thank you

Best Regards

Raffaele D’Antoni

pulsante Areatore Mento.SLDPRT.zip (2.54 MB)

Hi @raffaele-

Thank you for providing a sample file!

Unfortunately, I’m unable to reproduce this crash on my computer. Here are the steps I’m taking to try to make this crash.

  1. Downloaded pulsante Areatore Mento.SLDPRT that you provided.
  2. Launched Rhino 6 for Mac 6.17.19236.01022 and clicked New model to start a new Untitled modeling window.
  3. Run the _New command to bring up another Untitled modeling window.
  4. In the Untitled 2 model, I ran the _Import command.
  5. Navigated to pulsante Areatore Mento.SLDPRT and clicked OK.
  6. In the Solidworks Import Options dialog, left the defaults alone (see below), and clicked Import

Expected Behavior

The Solidworks part imports into Untitled 2

Actual Behavior

The Solidworks part imports into Untitled 2

What are we doing differently? If we can reproduce this crash, we can likely fix it.

(Note: I also checked 6.18 and I did not get a crash either)

Hi Dan, I tryed to follow you example by using the command “import” into an opened file I’m working on, and it import correctly. I have the problem when i use command “open” and select the .sldprt file. It only work if I just open rhino otherwise I have to quit the software by using “command-Option-ESC” key as you see in attached image.
Sometimes I prefer to open the .sldprt file as a new file and not import into the working file because if it’s a multipart file I can cut and paste just the object I need to import into my file.

Does exist a report file I can generate with rhino in order I can send you as soon as I have the crash?

Last thing i do not use the option “map Solidworks Y to Rhino Z” (as I can see on your image) because for me it’s not necessary infact I use the same axes as rhino into solidworks.

Thank’s again

Screenshot 2019-09-10 16.56.23.jpg

Hi @raffaele-

Thank you for that detail. That made me realize you were probably trying to open the same file twice, so I tried that and it hangs as you reported. Perhaps that is what you were attempting to convey. Sorry if I didn’t read it that way.

I dug up another sample .sldprt sample file and was able to open that at the same time as your file, so I can only presume you are attempting to open pulsante Areatore Mento.SLDPRT twice. That certainly hangs, so I will log it as such.

Interestingly enough, I am able to open my other sample .sldprt file twice without a hang and crash, so it might just be something about your file. Regardless, we’ll take a look.

If you know of a different way to demonstrate the crash, that would also help.

Thanks again!

Logged in:

RH-54704 SolidWorks import: Hangs indefinitely when attempting to Import attached file twice

OK Dan, as soon as it’s possibile for me i’ll send you a screen registration video to show you how my problem appear, and send you some more .sldprt files so you can test with much more files. Is there a way to send you big dimension files? do you accept we-transfer or dropbox or google drive shared folder?

Best regards

I think we have enough information to reproduce the crash as it stands now. It’s certainly a very similar crash. If you do have time to upload a screencast, that might help, or we can just look at the bug above and go from there. Thanks again for your help.

PS: Yes, you can upload file via shared folders on various drive services, whatever is easiest for you.