Rhino 7 ~ importing some Solidworks files fails

Importing Solidworks files is failing in my Rhino 7 Mac (retail)

Rhino 6 Mac worked fine in this regard, but 7 claims to successfully import an SLDASM file … but displays nothing.

I wonder if anyone else experienced similar?

The same file works OK in V6?

One import attempt reproduced only a small part of the model. That was after the programme was clearly trying to work due to the time taken. When if fails, it reports a successful import almost immediately. It has been a year since I tried Version 6, but I remember it imported lots of SW files and well.

You need to try with the same file on both - it could be a file issue, not a general one… Are all the individual .sldprt files available and in the same folder as the .sldasm? Also, what version of SW? Rhino may not import the latest version, it’s often a version or two behind.

1 Like

Thanks; I don’t know which version of SW; the files are ex-Grab CAD. Yes could be a file issue rather than a general one, so I’ll try with other SLDASM examples.

PS. It was a few files with which there was a problem; others imported okay; I jumped too soon!

YOU were right, it was a file (or a few files) issue rather than a general one.

Generally I am importing Solidworks files into Rhino 7 successfully.

I am unfamiliar with Solidworks. I don’t doubt that the file types sldasm and sldprt make sense within Solidworks.

Rhino imports equally both types, apparently without distinction. I assume there are no differences to be aware of after importing the two file types into Rhino (?!).


That would be an incorrect assumption… Solidworks .sldprt are individual part files, .sldasm files are assembly files - that put together the individual part files into assemblies.

The .sldasm file does not contain the part files, it just has information about how to assemble the part files together - origin, orientation etc. - therefore if you try to import a .sldasm file without the accompanying .sldprt files you won’t get anything.

I think the convention for importing a .sldasm is that all the files need to be in the same folder, you import the .sldasm into Rhino and it brings in all the referenced .sldprt files in the folder automatically.

You can also simply import individual .sldprt files directly into Rhino. If they are part of an assembly and you do not import them using the .sldasm however, they will not necessarily be in the correct location or orientation relative to each other, as that info is contained in the .sldasm file.



Thanks, that is helpful.

It also explains why Rhino 7 sometimes claims to have imported an SLDASM file successfully and with named layers listed and yet no objects are visible.