SolidWorks import broken


#1

Hi seems like SolidWorks import got broke on the latest WIP (6.0.17101.6541, 4/11/2017)

Eric


#2

OK narrowing this down a little, it appears Import of SolidWorks files works, but Open causes a crash.

Eric


(John Brock) #3

Can you please send us a small part file that crashes the WIP when Opened?


(Nathan 'jesterKing' Letwory) #4

Could you ensure you have in Rhino Options > Raytraced settings the viewport settings override disabled.

Does opening a SolidWorks file work better then?


#5

disabling this setting made no difference, Open still caused a crash.

Eric


#6

sent


(John Brock) #7

It Imports and Opens here without crashing.
How are you Opening it?
I ran the Open command from inside Rhino.


#8

Hi John,

It crashes if I type open at the command prompt, or use the open icon on the tool bar to select the file.

Do you want the crash report or did that get sent?

I have re-booted since the WIP install.

Eric


(John Brock) #9

Please repeat the crash and send in the report.
Reference this URL in the comments:


(Nathan 'jesterKing' Letwory) #10

This is most likely the same error as opening DXF and DWG files, which was reported earlier. I already fixed that. So next WIP it should be ok.


(Wim Dekeyser) #11

Just wondering if this also affects opening Rhino 3dm files?
I’m constantly crashing the latest WIP by opening 3dm file that were earlier saved by the RH6 WIP or RH5. I get the crash dialog and send that in but get redirected to a page titled “The resource cannot be found.” with the following content:

Server Error in '/crashdumps' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /crashdumps/upload.aspx


I suppose that means that those reports are not received…

(Pascal Golay) #12

Hi Wim - is this OK, with the latest?

-Pascal


#13

This issue appears to be fixed in the latest WIP

Thanks,

Eric


(Wim Dekeyser) #14

Hi Pascal,
Yes, this looks OK with the newest here. Thanks for following up!
w