Rhino Licensing UI Changes

@brian Do you think that this is due to trying get another validation key within 24 hours?

This is another area that needs explicit definition: In case of validation failure (for whatever reason - presently because validation process isn’t pretty) should the user get another validation code or just reuse the one that failed? Or do you reuse the one that failed if it’s within the 24 hour period and then get another one if the original is expired? So many unexplained uncertainties!

Seems to me that this would be a very frequent case.

Or, as is my case, that there’s some restrictions to the internet access…
The number of users in this situation should not be under-estimated: I think there’s a lot of users in corporate environments and these typically can’t install beta software - so they are under-represented here…

I should add that I’m sure there is a simpler way than going through the “offline validation” route. I have a lot of software installed that check their licenses on the net and they have no problem going through our proxy scripts…

I cleared your validations. Try again.

It’s because he’s been validating a lot as we try to get the validation system working. We don’t allow unlimited validations per user, so he just reached a limit.

Actually, this is not the case I thought you were in. There’s a different “Connecting to server” phase that happens before you are asked to enter your name, organization, address, and phone number. It appears that where you guys are failing is during online validation. I’ll have to see if I can figure out how to reproduce this. I’ll see if I can configure my gateway firewall to block access and get to the same state. Logged as RH-37698.

There might be. I’m happy to work with you to try to understand how to get through your proxy server. Right now, I appreciate your help getting this workflow to function before we add a new one to debug. Logged as RH-37699.

Maybe my Alzheimer’s is killing my short-term memory, but I thought the info above was requested by the online validation code generator, not the new offline Rhino installation. Just to be sure we’re on the same wavelength, let me reiterate that the no-escape Rhino-quit shown in Marc’s screenshot happened on the offline machine FROM RHINO after it got done loading for the first run after installation.

Or maybe I just flat-out totally misunderstood what you are saying.

The entire licensing and validation process goes like this:

  1. Select the license type (login, standalone, zoo). In this case, you both clicked Enter a license key, which is standalone.
  2. Enter your email and license key. Click Next
  3. Check internet connectivity and connectivity to the validation server

If the connectivity test fails, then we go to offline validation. This, I believe is where AIW heads. But given Marc’s screen shot, this step is succeeding and continuing with ONLINE validation.

Online validation

  1. Enter registration info. Next.
  2. Enter your profession and interests, click Next
  3. Enter other programs you use. Click Next.
  4. The Requesting validation code from server screen appears.

It’s at this point that validation is failing for Marc, and the weird double-dialog problem shows up. I tried to simulate this by disconnecting my network connection after entering information on the first registration page. But that doesn’t seem to give the user experience that you and Marc are seeing.

What I see is:

  1. Unable to connect to the validation server. Two buttons: “Get Validation Code Manually” and “Try Again”
  2. I believe you both click “Get Validation Code Manually”, then enter your validation code that you got from Validate - Rhinoceros
  3. Validation Successful.

I’d love it if both of you could go through this process again and record the process - either by naming the dialogs, taking screen shots, or a video.

I stumbled on a way to reproduce this problem today. I’m working on it.

Be glad to, but I did manage to eventually work my way to a successfully validated installation of this weeks WIP, so I guess I’d need to know what to expect if I try again.
Can I just try to reinstall this week’s again and expect it to request validation again?
Should I wait until next week’s and also expect it to request validation again instead of relying on the the validation from this week?

Marc’s picture represents at the upper left the validation window that came up after I entered the email and license in the first one. It shows an attempt to contact the validation server on my system which is not open to the internet. It stayed open as shown for a long time, perhaps 2-5 minutes, before the other window shown appeared. This was on the first run after installation.

After I said OK to the second window Rhino shut down and so did the upper window. It was not until the second time I started Rhino that I saw a similar window offering the opportunity to manually validate. When I took the manual option I was able to validate successfully.

No need - I can reproduce this problem here now. It’s really bizarre. I have to edit the code and cause it to fail in an unexpected way for the double-dialog problem to appear.

Thanks for that detail. That helps me understand more about what’s going on here.

A post was split to a new topic: Install WIP at home and work?

@marc RH-37699 is fixed in the latest WIP - when it’s convenient can you please try validating from within your proxy environment?

RH-37694 and RH-37674 are fixed in the latest WIP

It works!
Maybe only one little glitch;
-On the “Rhinoceros 6 Needs a license” screen, I chose “Enter your license key” (I was tempted to click on “Login”; what would have happened?)
-I entered the information
-I got the screen “Enter your Validation Code”. It probably remembered past attempts? I clicked on “Or, restart this validation wizard”
-The rest went on without surprises, getting the code manually via the webpage

Thanks for all this work!

We actually added proxy support to the Login process, too. So if you had logged in using a Rhino account with an email address that was used to validate a Rhino 5 license, Rhino would have “just worked”.

Ah yes, that’s because you did offline validation last time, and it remembered.

Wait. That’s not what was supposed to happen! You should have been able to get the validation code automatically from within Rhino, with no need to validate on our web site. Hmmm…

When I clicked “Or, restart this validation wizard” it immediately showed “Unable to connect to the validation server”

We are not simply behind a proxy server but a proxy scripts (that does some sort of balancing of traffic)

All program that connects to outside our network asks for our credential once every session. Chrome, for example, asks for our username and password every time it starts.

Hmm… then I guess there’s more work to do here.

RH-37674 is fixed in the latest WIP

Hi there,
I’m having trouble getting my latest install of r3d 6 wip licensed. Whether I try to license from the prompt on startup, or on the website, it’s telling me my I have an ‘invalid device ID’. The key I am using has worked fine with previous builds.
It sounds to be more of an account issue, but thought I’d raise it on this thread in case it isn’t.
Any ideas

It looks like you got your license into your Rhino account successfully and are now running. Is that correct?

Ditto - I’m having the same issue. Any suggestions on how to fix this?

An “Invalid device ID” error means you installed your V6 license key exclusively on a different computer.
To install your license on a different computer, you’ll need to return the validation on the first computer.
This is why we are strongly recommending using the new CloudZoo through your Rhino account so you can float your single license between all of your computers.