Rhino isn't remembering command history

I just installed Rhino on a new Macbook and it no longer remembers my most commonly used commands between sessions. Whenever I start the program, I have to ‘train’ it again to know which command I want when I type out the first few letters. I know in Rhino for Windows there is a fuzzy autocomplete setting but I can’t find anything like that in the Mac settings.

Please let me know if there is a fix for this. I’ve tried deleting and reinstalling Rhino but it’s still not working.

I do not think there is a command history between the Rhino Mac sessions.
Additionally, the Worksession command is not currently supported.


I’m sure there was because it remembered everything on my old Mac even after restarting the computer. Have they removed this feature in a new update? That would be really disappointing.

i also had the feeling that this was better before, but since it always felt a little awkward because i am actually working in wips only, i kind of tolerated it for now. would be nice if this could improve.

Related: is Middle Mouse button > Most recent commands popup still not implemented?
I used the mac version only a few times, and the option was nowhere to be found… I don’t know many people who use it, but my workflow depends on that little function.

Just an idea. Maybe quacosa here can be done?

Hi Tim, i don’t know if you find a solution, but maybe this will help you out…:thinking:

see it’s under the tools menu - and i can switch that on/off by using F2… ?!?