Rhino.Inside won't load in Revit 2021

Hi @Aziz.BOUKARA,

Take a look at this please Rhino Inside Revit WIP Build Expired - #4 by kike

Merci Kike

Hi.

Thought I should let you know that I’ve recently rolled out Revit 2021 (21.1.30.74) and Rhino inside (0.7.7823.23032), and am facing the same problem. The InstallLocation registry value’s data is just “Revit 2021\”:

So when I try to install Rhino Inside, it says “Could not access network location Revit 2021\.”

image

Putting the correct path in the InstallLocation value, fixes the problem.

Thanks.

Hi @itsupport6,

Rhino.Inside installer fallsback to “%ProgramFiles%\Autodesk\$(InstallLocation)” in this situation.

Isn’t your Revit installed at “C:\Program Files\Autodesk\Revit 2021”?
I saw other users having the same problem because it was installed at “C:\Program Files (x86)\Autodesk\Revit 2021”.

Thanks for getting back to me, Kike.

The install location (which I haven’t changed) is actually “C:\Program Files\Autodesk\Revit 2021”.

The registry fix I’ve implemented looks like this:

Thanks.

Looks like there is a bug-change on the Revit installer.

For Information: Revit 2021.1.2 Hot-Fix and InstallLocation - Autodesk Community

Autodesk Revit 2021.1 Hot fix change to Autodesk.RevitAddIns.InstallLocation - Stack Overflow

Maybe InstallPath is now mandatory on Deployment.xml.

Change product installation location | Revit Products 2021 | Autodesk Knowledge Network

1 Like

Thank you very much, Kike. I’ll take a look.

1 Like

Actually, I had already looked at all those.

I think that last one might be out of date, as a deployment I made within the last few days doesn’t contain a file named Deployment.xml. Instead, it contains a file called Collection.xml, which does include an InstallPath entry, but that is pointing to C:\Program Files\Autodesk\, already:

image

Either way, this is just another Autodesk problem, and I’m happy with the solution I’ve implemented (I’ve used a GPP to update the registry value), which does enable Rhino Inside to install.

I just thought you should be aware that the fallback you mentioned doesn’t seem to be working for some reason.

I’m happy to provide more information and help with testing, if you like.

Thanks.

David.

The way the fallback is trigered is when Revit.exe is not under Install Location.
In that case prepends “C:\Program Files\Autodesk” to InstallLocation else does nothing.

I’m wondering if you are running the installer from “C:\Program Files\Autodesk” as your current folder.
In that case the installer will miserably found the Revit.exe and will not prepend “C:\Program Files\Autodesk” and will fail.

We are checking for relative path before doing anything.

@itsupport6

Could you please, do this while your InstallLocation is “Revit 2021”?:

  • Download this file RhinoInside.Revit.txt (65 Bytes) at the same folder you already have ‘RhinoInside.Revit.msi’.
  • Rename it from ‘RhinoInside.Revit.txt’ to ‘RhinoInside.Revit.bat’
  • Double click on ‘RhinoInside.Revit.bat’

A file called RhinoInside.Revit.log will be generated, please send it back here.

Thanks.

Okay, this is strange. I wanted to triple check that the problem was still occurring, before using your batch script, so I tried the process as normal, and it worked.

Now, I can’t reproduce the problem. I removed the GPP from the test computer, checked the registry value again and again, and Rhino Inside always installs without a problem now.

I have no idea what’s changed, but if I find anything relevant, I’ll be sure to let you know and give you that log, if it happens again.

Thanks for your help!

1 Like

Heyyyy… I have the same issue… and I think I followed most of the great advice here, and restarted a bunch of times… even reinstalled Revit and deinstalled other Revit-apps that might be conflicting…
So when I try to start RhinoInside by pushing the start-button, nothing happens. I just updated to the latest WIP, and didn’t have any trouble with the last one.

I have trouble sorting out which installation-path I should enter through this thread so I wanted to double-check with you if this is correct?

Would be very thankful for any hints on what to try next as I’m on a deadline :upside_down_face:

installation path

… for the record, it won’t load in earlier versions of Revit either…

Have a nice day! Greetings from Norway

Doesn’t this fix the problem in your case?

Hi,

I am having some of the same problems. Last version worked, updated and now it does not start. I am using Revit2020. Installed: C:\Program Files\Autodesk\Revit 2020

Registry looks like this

RhinoInside.Revit.addin file is present the %PROGRAMDATA%\Autodesk\Revit\Addins\2021 folder

Any suggestions?
Thanks!

Hi @sigurd,

You mention “Last version worked, updated …” do you refer to Rhino.Inside, Rhino or Revit?

When you said “…and now it does not start” you mean:

  • Rhino.Inside does not appear on Revit UI at all.
  • It appears but gives you an error message when click on ‘Start’.

I see on your screenshoot that you are using Revit 2020 but you mention it is installed on %PROGRAMDATA%\Autodesk\Revit\Addins\2021 is it also installed at %PROGRAMDATA%\Autodesk\Revit\Addins\2020?

Hi Kike,

Thank you for replying!

  • “Last version worked” refers to the previous Rhino.Inside

By it does not start now i mean;

  • Rhino button appears in Revit, but nothing happens when i press it. (on the previous rhino.inside version there was a toolbar with several buttons i remember). No error messages when i press it.

**" I see on your screenshoot that you are using Revit 2020 but you mention it is installed on %PROGRAMDATA%\Autodesk\Revit\Addins\2021 is it also installed at %PROGRAMDATA%\Autodesk\Revit\Addins\2020 ?"
– Sorry! I copied that text from a previous post and forgot to change to 2020. Yes it is installed in `%PROGRAMDATA%\Autodesk\Revit\Addins\2020.

Please press ⊞ Win+R and run “regedit.exe”

Go to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\Rhinoceros\7.0\
and verify your registry looks like this.

Is Version 7.6 at least and Path correct?

On this exact path i get nothing: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\Rhinoceros\7.0

But if i select “install” i get this:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\Rhinoceros\7.0\Install
Path seems right, but the version is 7.4

Rhino.Inside should warn you about Rhino 7.6 is needed now.
Sorry about that.

Pleas update Rhino.

Thank you! I will try to update Rhino