Rhino.Inside dont load

I have Revit 2019.2, Rhino 6, Rhino WIP
If i want to load Rhino.Inside from Revit i see error:


Thanks for those detailed screenshots.

I’m not sure what is happening here, so I’ve added a more detailed error message in that case.
Could you please update you Rhino.Inside Revit copy from here and share again the new error message you will have?

Thanx for reply.
I had installed new version by your link. But i have error on the screenshot.


I did some changes to show more information.
In case of error, it tries to recover as well, so please test you have or have not the Revit tab in Grasshopper.
If you have an error please share it again.

The new installer is at the same place.


The message is after pushing Rhino WIP:

Then error:

Hi again,

I did more changes to have a more specific error message.
The new installer is as before here.

Please try again.

After the new installer:


I did more changes.

Before update could you please load again the version you already have installed and after the error message show Rhino console, Grasshopper prints some error messages there in those cases.
If there is something there please share it here.

After this test update your RiR copy and test again.
I did a new change that may fix a problem when the user have low privileges on the computer.


I had the same problem as Sergei.
I installed the latest Rhino.Inside WIP, Rhino and Grasshopper are running again from Revit.

Thanks @agnes_tan for confirming it.

It seems that after 4 tries we found what was wrong.
I hope it fixes @volkovsergei case too. :crossed_fingers:

After the lastest installer again the same error. May be i something do wrong.



Could you please take a look at the Rhino console if there is any message there?
Also, please double-check Grasshopper is this one.

This same issue/error happened to me a few weeks ago. I troubleshot for a while, and to my surprise by opening Rhino7WIP outside of Revit and then simply closing it after its boot menu the issue seemed to be fixed when opened Rhino.Inside within Revit. Not sure if this was a happenstance or it had something to do with the licensing but could be insightful for you Kike.

Fast forward to this week, I ran into the same error message as Sergei. After reinstalling the latest Rhino.Inside WIP that Kike posted yesterday the problem was fixed and I am now able to open RIR. That being said, after executing that new installer, I am now running into the issue posted here:

RhinoInside not finding Revit categories/ levels/ etc

Not sure if the new installer and this error are correlated or for that matter change the thread topic, but thought it would be worth sharing the information in case it helped in out in anyway. .


May you copy and paste here the last line.
The one that starts with ‘Message:’.

My Russian is действительно плохо.

Working!!! I just restart windows.
Thanks you very much for your fine answers.

I have the Revt tab but where is dropdown list in Model Category picker?


I have every addin except RhinoInside disabled, but cannot see Revit categories in Gh.



Could you pleas try updating again and tell me?

Its great! Working! Thank you very much!