Rhino.Inside cannot load

Hello!
I just upload the Rhino7 licence and downloaded new Rhino.Inside and Rhino7 today. But Rhino.Inside can not run under Revit 2019.2. “AssemblyResolveEvent handlers cannot return assemblies loaded for reflection only.” I have used Rhino.Inside under this Revit version for a long time with Rhino6 WIP.
微信截图_20201229224734
Rhino version is 7.1.20343.9491 Rhino.Inside version is 0.0.7662.10129
Thanks for any help!

Hi,

I’m no able to reproduce this problem here, but I did some changes with the intention of fixing or try to track down what happens a bit better.

Please update from here RhinoInside.Revit-20201229.msi.zip (4.1 MB) and tell me if this works on your computer, if it doesn’t work it will show more information on the error message.

3 Likes

It works now!Thanks a lot :laughing:

1 Like

Wow, that worked for me too! I had a similar/the same issue and this solved it. Funny thing was that it manifested with Revit 2018 and 2020, but it worked fine with 2019/2021.

Thanks a bunch, Kike!

Nice, this looks like a conflict with another addin that you have installed on 2018 and 2020, but not in 2019 and 2021.
Since we can not test every possible setup the user may have, we have tried in this release to make the load process more robust to “any” unexpected circumstance.

Hi Kike,

I’m having the same issue with the latest release. I’m running Revit 2021.1.2, Rhino (7.4.21078.1001, 2021-03-19). Just downloaded the latest release of Rhino.Inside.Revit, un-installed the previous version and installed the latest.

image

You mention a conflict with add-ins. I’m running Conveyor from Proving Ground which is all I can think of that might cause a conflict. I’ll reach out to Nate and see what he says but do you have any other suggestions?

Cheers,
Jon.

Would you mind following this guide to find the conflicting plugin?

https://www.rhino3d.com/inside/revit/beta/reference/troubleshooting#search-for-conflicting-plugins

Thanks @eirannejad. It’s clashing with my Egnyte file sharing add-in. So now that I have narrowed it down what’s the next step? Do I report it to McNeel and see if they fix it or do I report it to Egnyte and ask them to fix it or both?

Yeah sure reporting to Egnyte is very helpful as well. You can also follow this to send us a debug package so we can look at possible dll conflicts

https://www.rhino3d.com/inside/revit/beta/reference/troubleshooting#submitting-debug-info