Rhino.Inside.Revit 2020 Installation problem

Hi there,
I just tried to install Rhino.inside.Revit and the installer gives me the following error. I have well installed and running the latest version Rhino 7 and I have Revit 2020. Could somebody advice me on how to solve that? thanks

Is your Revit somehow virtualized using Citrix or something like this?
In that case you will need your admin installs it on the server.

Hi Kike,
Thanks for your quick reply. Yes, it is a Virtual Machine in Microsoft Azure on which Revit is installed. But it is a local installation and I have full administrator rights on this machine. So the IT team doesn’t know what it is really the problem.

Hi again @kike,
I text you back again, because there has been some development in my problem.
The new RiR installer runs smoothly now without any error and goes all the process indicating at the end that it is successfully installed. But when I open Revit it is simply not there. The IT doesn’t understand the problem, he tried himself to install it unsuccessfully. In comparisons when I go to Revit Addin folder there are other plugins that have been well installed and running. Do you have any idea of what can the problem be?

Hi @pablo.desola,

Please open Windows command prompt, run msiexec /i "RhinoInside.Revit.msi" /L*v "RhinoInside.Revit.log" there and send us back ‘RhinoInside.Revit.log’ file.

Hi @kike, this is the message I get.

Ok, do this then:

  • Download this file RhinoInside.Revit.txt (65 Bytes) at the same folder you already have ‘RhinoInside.Revit.msi’.
  • Rename it from ‘RhinoInside.Revit.txt’ to ‘RhinoInside.Revit.bat’
  • Double click on ‘RhinoInside.Revit.bat’

A file called RhinoInside.Revit.log will be generated, please send it back here.


Here it is:
RhinoInside.Revit.txt (197.8 KB)

Hi @pablo.desola,

It looks like your user profile is synchronized to a windows server.
Are you using something like Citrix or equivalent to share Revit across the office?
In that case you should install the Addin on the server, at same computer as Revit is installed.

Hi @kike
To be honest I don’t understand very well how all this is working. I started new in the office not long ago and found myself in this situation. So far, what I know is that we use Azure as a remote system computer system. But the IT insist that my computer works like a normal one and that I have everything locally installed.

Do you have a file called Revit.exe at C:\Program Files\Autodesk\Revit 2020 folder?

It is here: C:\Program Files (x86)\Autodesk\Revit 2020

This is weird because Revit 2020 is 64 bits only.
Is there any 32bit installer for Revit latest version? | Revit Products | Autodesk Knowledge Network

As a 64 bits application Revit should be installed under C:\Program Files.
C:\Program Files (x86) is only for 32 bits apps.
WOW64 Implementation Details - Win32 apps | Microsoft Docs.

So reinstalling Revit under C:\Program Files should solve this problem.


Ok, I will try with the IT to install Revit again and see if that works. Thanks for your help @kike . I will keep you posted in case it works or not.

Hi @kike,

It finally works. I reinstalled Revit in the correct folder then RiR and works so far. Thanks a lot for your help.

1 Like

Hi I am unable to install rhino.inside for Revit 2021. The message box is the same as the first post image. I don’t have the option to reinstall Revit because I am on my work computer. I have tried installing on my windows profile inputting Admin password, I have also tried logging in as admin and installing there. Both times I get the message “Can’t access Revit 2021”. Is there any solution that doesn’t involve reinstalling Revit, which my IT department won’t do.

Hi Murphy, if you have the same message as I had, I think you should reinstall Revit. That’s what we did here and it worked.

My IT department won’t do that.

Then you should ask McNeel people! I don’t know another solution.

1 Like

Hi @kike
I just updated RiR. Works fine in Revit 2022, but my project is in 2021.1.4, and in 2021 it looks like the latest installation did not update it at all :confused: .

My button looks like this

And nothing happens when I hit it…

If I hit the options button I get this:

How can I make sure that running the installer from the website is actually updating the revit2021 version of my RiR?