Rhino.inside - Rhino window right click on layer doesnt work

Right click on all layers (native to current rhino file and worksession file) doesnt show me the menu options. I checked in a regular rhino 7 file and right clicking on layers works in it. This problem is consistent with all rhino.inside files I have atm.

Using Rhino 7 and Revit 2021.1.6

Hi @srujan.v16,

Are you talking about this context menu?

Hi @kike thats correct. This menu doesn’t show up only when I use Rhino.inside with revit 2021 and RHino 7. Havent cheked other revit versions yet.

srujan, I’m not able to reproduce this.

Can you provide more detailed system info

As well as the info that typing in SystemInfo in the Rhino command line provides. Thanks


Rhino 7 SR17 2022-4-12 (Rhino 7, 7.17.22102.05001, Git hash:master @ 13b57035af8fb22da005ef72c56e4555d9dbcfe3)
License type: Commercial, build 2022-04-12
License details: LAN Zoo Network Node

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 Super with Max-Q Design (NVidia) Memory: 8GB, Driver date: 3-17-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 512.15
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\svichare\Documents\Grasshopper_Plugins\elefront500\Elefront500\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Mindesk\Rhinoceros\Mindesk.rhp “Rhinoceros® Link for Mindesk”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.17.22102.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Please let me know if you need anything else. Cheers

Srujan V16,

Can you see disable the Elefront and Mindesk via Plugin Manager and restart your Rhino.Inside.Revit and see if layers are behaving as expect?

And to confirm, you aren’t seeing this behavior in a standalone Rhino session?


Hi @Japhy ,
Thanks for the advice. I am not sure if its the latest rhino.inside update that dropped today or the disabling of plugins but it worked. I can access the layer context menu now.

And to answer your question, this behaviour/issue only appeared with revit and rhino.inside. Standalone Rhino is working well.


Edit : Spoke too soon
The context menu problem is back.
Also noticed other context menus display out of proportion

It goes beyond the edge of the screen

Can you go down to one display to trouble shoot this? The setup (resolution & alignment) of the multiple displays might be a factor. Thanks