Rhino Inside Revit won't load up


We installed Rhino.Inside Revit in a couple of our machines but we keep getting the below error…Keeps asking to download latest version but we have done that several times already.

The version for Rhino.Inside Revit comes as which is weird

We have the latest Rhino 6 and Rhino WIP so unsure what is happening here? has anyone had this issue

There are a few things to check here.

  1. Run Rhino 6 by itself, does it start and is it licensed?
  2. Run Rhino 7 by itself, does it run?
  3. Make sure the most recent Rhino.Inside.Revit link is installed: https://www.rhino3d.com/download/rhino.inside-revit/7/wip
  4. Try and run Revit again and load Rhino.

If this does not work, The code just looks at registry (RegEdit) here HKEY_LOCAL_MACHINE\SOFTWARE\McNeel\Rhinoceros\7.0\Install for a value called Path that contains the Rhino 7 WIP installation folder. What does that value contain in your case?

1 Like

Hi Scott,

We checked in here but for some reason we cannot see Rhino 7 in the registry or the c:drive program files (see image below)

We followed all the steps but not entirely sure what’s wrong. I can open Rhino 6 but if I try to open 7 it opens 6 again and I get an error (see second screenshot below)

Any help would be very much appreciated

Thank you

Hi Diego -

How are you trying to start Rhino 7 WIP?

Hi Wim,

Well at the moment I’ve tried as per my screenshot below, as I don’t have a Rhino 7 WIP shortcut on my desktop. So just do that and try and open it normal or as an administrator but either way Rhino 6 opens on and not 7 WIP

Do you have any ideas?

Hi - the icon there shows Rhino 6 so, clearly, there’s something wrong. (Also, it should be “Rhino WIP” and not “rhino 7 wip”.

Have you tried right-clicking on Rhino WIP and picking Change in the list of programs in the Windows “Programs and Features” dialog?

Hi Wim, we did as per your post above and now it works in my computer. Thank you for that

We did came across another issue though, in one f my colleagues machines we got the below error when trying to open rhino.inside. I believe this is got something to do with Pyrvit as he has it on his machine. I don’t have PyRevit installed so I think that’s why it worked for me. Do you know if there is a solution for this?


Please open the PyRevit about box on the computer that is not working and take a screenshot. Normally a newer version of PyRevit is needed to fix the problem.

Hi Scott,

We installed the latest version of PyRevit and that seems to have worked now. Rhino.Inside Revit opening without any issues.

Thank you for the support

1 Like